Trados confirms all segments

Dear All,


I work with Trados 2017. There's this thing that keeps happening to me and that is driving me round the bend: 

I seem to be hitting some weird combination of keys that causes Trados to mark all segments as translated, even empty ones. I know how to undo the damage (just change segment status), but what I'd really like to know is: What's causing it? Is there a key combination or button that I am inadvertently hitting?? 


Grateful for any ideas on what's going on...


Parents Reply Children
  • 1. Now I´m using Studio 2019 ver. But this is problem known to me since years, in Studio 2014-2017 too.

    2. No filtering, all segments in the file are displayed. I select 3 contiguous segments of course - with the mouse or with Shift+Down/Up. Then I conform with the hotkey "Confirm and move to next unconfirmed segment". Or with "Confirm and don´t move to the next segment".

    I tried it right now with a huge file I´m working on. All remaining 500 empty segments were confirmed. Studio froze for several minutes. Then I found out, that CTRL-Z has stopped working once again...

  • Former Member
    0 Former Member over 1 year ago in reply to Adrian Palme

    That is happening from time to time.
    -I am a version 2017 user, have no idea about version 2019

  • Have you checked, if the shortuct for confirming all segments isn't active in your Studio version?

    When CTRL+Z stops working, you have to close Studio and restart it. Usually, when that happens, Studio will freeze in the near future or crash completely.

  • Why don't you simply change the status for such selected segments? Confirming several selected segments with the hotkey is not the way it is supposed to work. The hotkey is for confirming single segments only - at least this is how I understand working with Studio. For confirming several selected segments in one go I always use the "Change segment status" feature - either right click or the one from the ribbon.

  • The shortcut for confirming all segments is not active.

    As for not working CTRL+Z: I was told by the SDL support, that this bug will be corrected in S2019 SR2. Did not happen.

    I suppose that restarting Studio all the time is not the way translators want to use it on daily bases...

  • When I e.g. provide a global "Find and Replace" and I want the changes to be saved in the TM, I need to confirm the segments. It is not enough, if I only change the status. Right?

    Or it can easily happen by mistake - you select text in 2 different segments by pressing e.g. Shift+Down. Then you confirm. And the accident is happened... 

    If the "hotkey is for confirming single segments only", it should not be possible to confirm multiple segments. Just my opinion. And if it IS possible, it should work properly and safely for the user. With respect to his time and work!

  • Unfortunately it is the same in 2019 too. 

    More specifically, this "feature" is available since Studio 2014.

  • It really depends on the way you work. When searching & replacing, I do not need to have the segments updating my TM in this very moment, having changed the status to "Translated" or whatever needed is enough.

    I never select segments via shift+down, simply because I use ALT+DOWN to select segments when I need to merge them. For confirming batches of segments when I use display filter I only use the segment status change. Should I really need these segments being updated in the TM, I would then simply run the proper batch for it.

    And it is not necessary to restart Studio so often, usually I do that only few times a week. For example I am now working on a 84,000 words document and have kept Studio with this file open for several days, powering the PC down only yesterday...

    Now I have tried to select two unconfirmed segments in Studio with SHIFT+DOWN, then pressed the shortcut for confirming the segment. Only one segment (the first one) got confirmed, the second one was not confirmed. Same happens, when I activate both segments - so I cannot confirm the problem reported here. Nothing similar happens here.

  • 1. I NEED to confirm the segments and to save the content in the TM, because otherwise I would use the old content (ev. with errors) in the future (maybe even in the next minute).

    2. I really do not know, how YOU work. I report here a problem, that I´m experiencing since years.

    3. It IS necessary for me to restart Studio, if it STOPS WORKING PROPERLY. If it would work for weeks without a damned bug known since year, I would be glad, if I would not have to restart it. Trust me.

    4. Good for you, that it works. There is even a difference in the behavior, if you select the whole text of the first and the last segment or just a part of it. Trust me, I´m not spending time here with an not existing problem.

    Since I see that this discussion leads to no result, I would like to conclude it with only one thing. I have noticed several times the errors reported by users are either simply ignored or they are pushed to the users themselves. Once I have reported a bug and got the answer "This is not a bug, this is a feature". What a surprise that this feature suddenly disappeared in the next release... 

    Is this the way, how a developer support should work?

  • I am not a developer, just a user like you.

    If I answer here, I spent my free time for this. Trying to reproduce your problem I cannot find any problems in Studio. What I report is the behavior of Studio on my machine. This is a pity, Studio does not work properly on your machine. So there must be a difference between these 2 machines... Unfortunately Windows PCs may differ in so many ways, that it is next to impossible to find out what's causing this unwanted behavior here and there.

  • Hi Jerzy,

    Sorry, I thought you are some of the SDL beta testers answering here. Thank you for your time and for trying to help me to reproduce the problem.

    I´m quite angry, because I have to deal with many problems with Studio 2019 and nobody from SDL is able/willing to solve it. The most interesting thing: the trial version worked fine, the problems started after the activation when I have purchased the license. But the problem described here regarding the confirmation of segments persists since Studio 2015. Like many others, e.g. the CTRL+Z bug, the stability of Studio, slowly working TM´s, randomly not working QA check etc. etc.

    Thank you for your effort, I wish you a nice evening!

    Best regards, Adrian 

  • Hi Adrian

    FYI: I belong to the beta testing team, but am a freelance translator. I am using the software - beta or not - for translating quite a big files and cannot really report so many bugs like you guys. Well, Studio is fairly not perfect and there are certainly bugs here. But not working CTRL+Z or not working shortcut to go to TB search are not the case on my machine. As I wrote above, when CTRL+Z stops working on my machine, this is a sign of instability and means Studio will crash very soon. So then I restart the program. But I keep my PC running for several days and Studio open with big files (like now, over 80k words), as opening such big files does cost me time.

    I know random problems do occur, but usually they occur also shortly before a program crash.

    It would be good to know, if you're using the program in a virtual machine, on a Mac or in other environment. Which anti-virus solution is running in the background. Which programs are running in the background. What is the language of your OS. Are your HDDs encrypted. Where are you files and TMs/TBs stored. All this are factors, which may highly influence the behavior of Studio. Are you using voice recognition? Do you have many add ins installed in Studio? Any programs catching shortcuts? Game software? Game hardware?
    For example, since I moved my TMs/TBs from a SSD to a M2 HDD, Studio is working faster.