Context matches appearing as 100% only in the editor (studio 2019 SR1)

Dear all,

 

has anyone noticed something strange with the context matches in Studio 2019?

The analysis says there are 5 context matches (for the 5 sentences I just translated to the TM)

When I now delete all target segements and run a pre-translation, all  segments come up as CM.

But if I delete all target segments and manually click into the segments, only the first one comes up as CM, all the others show 100% between the segments and in the TM window.

When I click again into one of the segments, the TM window switches to showing a CM instead of a 100% match.

 

Has anyone seen this behaviour as well? Any idea what is happening here?

Thanks

Angelika

Parents
  • Hello

    Could you please walk me through the steps you took here, so I have a better understanding of the situation?
    This is not something I have encountered, what I gathered from the description so far.

    So here you have a new file in Studio, where the analysis says that there are 5 CMs from your TM.
    Or have you translated the file already, and re-analysed it, and this is where the CMs are from?
    And then you delete the translations from the file and re-apply the translation from the TM?

    Please confirm the process you used.

    Hoping to hear back from you.
    Best wishes,
    Greta

    Greta Magyar - Customer Success Representative - SDL

  • Hi Greta,

    thanks for getting back to me. Here is what I did:

    Opened a file with 5 segments for translation in Studio
    Translated all 5 into my TM
    Deleted the target segments
    Run an analysis (5 CM)
    Run a pre-translation (5 CM visible in the pre-translated file)
    Deleted the target segments again.
    Clicked into the first segment segment
               1st segment appears as a CM in the editor and in the TM window
               Confirmed the first segment
               All following segments are inserted as 100% matches
    Clicked inside one of the 100% matches -> Now the TM window above shows a CM

    Hope this makes it clear.

    Let me know if it happens the same way for you.

    Thanks,

    best regards

    Angelika
  • Hello

    Thank you very much for your detailed answer, all is clear now.
    This is an automation in Studio. Whenever an exact match is found, it is confirmed automatically and then the next one and so on.
    In case you would not like to use this functionality, you can turn it off in Files > Options > Editor > Automation > Apply best match after successful look up

    Best wishes,
    Greta

  • Hi Greta,

    I think the issue that I have is not clear yet.

    The issue is that I expect (and have seen that in previous versions of Studio) a CM to come up as a CM always. So If I confirm a segment and the next segment has a CM I expect it to show a CM between the segments, not a100% match. I would like to know why it shows 100% as status in the editor, but CM in the TM window.

    thanks

    Angelika

    By the way, I have been a trainer for Trados fo 20 years, so this is not a question about how to use Trados Studio :-) I just found that the behavior does not seem logical.

  • Hi

    Quite an interesting one.  If your computer is not too fast you might notice that when you arrow down through the segments the match value in the TM results window flashes 100% before turning to a CM match.  It's pretty fast, but you can see it and this gives the clue to what's happenning.

    Go into File -> Options and turn off the "apply best match" after successful lookup and do it again.  This time you'll see a 100% match in the TM results window.  If you apply the match you'll see 100% in the segment and a CM match in the TM results window.  It should be a CM match so the question is why isn't it a CM initially, except for the very first one?

    The answer is lookahead.  If you repeat this again but this time turn off lookahead you'll get a CM match in the TM results window, and a CM match in the editor... as expected.  The reason for this is that Studio caches the results of the next few segments when you start in segment #1.  But because you don't have a result in the targets yet you only get a 100% match cached.  But when you enter these segments the TM results window will correctly display a CM match because everything is now there to trigger it.

    It's a bit of a weird situation but I think it's behaving logically with these settings.  Does that make sense?

  • Hi Paul,

    thanks for the explanation. It does make sense and is logical. But this behavior will also give rise to a lot of discussions between PMs and translators and questions to the support team by PMs who see different things in the analysis and in the document. It is a matter of how much can they trust the analysis results when the document shows something different.

    And as you know, CM and 100% matches have a different price. The translator might notice that they don't get paid for CM, but in the document they see mostly 100% matches, which they should get paid for.

    As much as I like the idea of the lookahead, the feature does not behave intelligently enough to be self-explaining or logical to someone who does not know the details about it.

    This is just out of my experience as a trainer who has to explain these things :-)

    Thanks,

    Angelika

  • Hello to all,

    I'm coming across this issue now, in some of my files. I recently upgraded the TMs (we are in Studio 2017 SR1 - 14.1.10017.54688). I do not have Look Ahead enabled in File | Options. Similar to Angelika, we now have issues with the linguists saying they need to be paid more, as they can no longer tell what is or is not a Context Match, without looking in the Translation Results window - the editor window says everything is a 100% match. If this will continue to happen, I worry that I will not want to upgrade any more of the TMs. 

    Is there a suggestion how I can explain the difference to the linguists, so we don't get charged more? I would like to avoid  pretranslating all the files before the Studio packages are made. We have considered upgrading to 2019, but I am not a big fan of the Project Setup wizard, with selecting the languages for a project.

    I look forward to hearing from you.

    Best, Mindy

  • Hi

    I think the solutions are probably these:

    1. you pre-trnslate the files first and this removes all doubt since it also provides the translator with the exact reasons for the analysis in the first place, or
    2. you advise the traslator which settings to use when working

    I think the first option is the better one.

    We have considered upgrading to 2019, but I am not a big fan of the Project Setup wizard, with selecting the languages for a project.

    What don't you like about it?  I think it's much faster now as you only need to remember the language codes which I imagine are second nature to a PM and then it's really fast.

  • as you only need to remember the language codes which I imagine are second nature to a PM

    Hmmm, FWIW, my experience is that only very small minority of PMs (i.e. only the old farts with IT knowledge) had some knowledge about language codes... the young twenty-something's usually had no idea.

Reply Children
No Data