Spell check 'resume bug?

If the spell check is running (F7) in Editor and the mouse is used to click in a segment to make a correction or even outside Studio to do something else (taking Windows 'focus' away from the spell check), pressing 'Resume' often causes Studio to restart the spell check at the beginning of the file, so the user is left waiting (with a big file) for a long time until the spell check again reaches the point at which 'focus' shifted. If this occurs after 5-10 minutes checking a big file, it is very frustrating to wait for the check to begin again from the beginning while being unable to do anything else on the PC while this is happening.


For example, when the spell check picks up a double word (e.g. "that that" when it should read "than that"), spell check offers the opportunity to delete or correct the second word, but clicking in the segment to correct the first word resets spell check to restart at the beginning of the file.


It would be great if the spell check could be interrupted and resume immediately at the same place, without re-checking all the segments already scanned. If focus is taken outside Studio or when clicking from the spell check dialog to a segment in Editor view should not 'reset' the spell check. In MS Word, when you interrupt spell check to open a new e-mail or do something else outside Word, spell check resumes from where it was interrupted.

Or is it me? Am I doing something wrong? (I have also added this as an Idea in the Ideas forum).

Simon

Parents Reply Children
  • Switching to Hunspell will not solve the problem of the spellchecker starting again from the cursor after a "Resume", I tried that a while ago (see the link I posted in this thread). It might be faster though - I could well imagine that.

    Daniel

  • Hi

    I'll be a little more precise ...

    For me, both Word and Hunspell checks proceed as follows:

    When resuming the check after stopping and clicking into the SDLXLIFF to manually adjust or check text... If the cursor is placed after the position the spellcheck had reached then the check continues from exactly that place in the text. BUT if you place the cursor at the beginning of the text or anywhere before the position the spellcheck had reached, the check resumes from precisely the point it had already reached. It does not recheck anything that has been checked and it does not flag up anything that has been given the 'Ignore all' command during the current spellcheck before it was stopped.

    As I understand it, the problem that was reporting is that the spellchecker restarts at the beginning again and rechecks text it has already had instruction to ignore.

    I cannot reproduce this behaviour with either Word or Hunspell spellchecker. If the problem was due to Simon's Microsoft Office/Word setup then the Hunspell dictionary might be OK...

    As the normal/intended behaviour of both spellcheckers is present on my system and this problem isn't frequently reported, it would seem that it is set up correctly. It is difficult for SDL to define why it works properly on some setups and not others.

    All the best,

    Alison

  • Hi

    I think it's pretty clear that and I are experiencing the same behavior of Studio. Since he only uses "Ignore all", he is not prompted to again deal with previously "ignored" words. - he only feels the time Studio needs to process the segments again.

    I must confess I was not clear in how I described the issue in my post above (I'll correct the post to avoid leading others astray): I said Studio starts from the *cursor position*. That is not the case. It starts from the *active segment*.

    You should be able to reproduce this with any text that contains at least two wrong words in two different segments. Activate the first segment of the file, this makes the spell checker start from the beginning. Select "Ignore" for the first misspelled word, then the spell checker will progress to the second misspelled word. Note that the first segment stays active.

    As you are promted how to deal with the second misspelled word, select "Options", then "Cancel". This is sufficient to make the spell checker want to "Resume". Select "Resume" and you will see that it will again prompt you for the first word you told it to ignore before.

    This is the same whether I select Hunspell or MS Word. I'd be keen to know whether you can reproduce this.

    Daniel

  • Hi 

    Yes, I can produce that behaviour.

    To add to this, if I 'ignore' the first 'wrong' word then 'change' the second one from within the spellchecker, then when prompted to check a third 'wrong' word, if I then click 'Options' then 'Cancel', the spellchecker returns to the changed word, not to the first word ignored. So, it does not return to the beginning, but to the last changed word whether you place your cursor in the text or not. 

    When I want to stop the spellchecker to do something to the text, I don't click 'Options' unless I actually want to change the settings. I would guess that clicking 'Cancel' is what resets the ignored words.

    If I want to change the spellchecking options, I generally do that before I start spellchecking. If I want to make a manual change to the text while I'm spellchecking and I can't do it from within the spellchecker, then I click into the text to do it. Once I have made whatever change I wish to make, the spellchecker then proceeds from the same word it just flagged up or, if I've corrected it, the following word it finds.

    For me, that's how a spellchecker should work.

    I do see your perspective, however ;-)

    All the best,

    Ali

  • Hi

    I came across this not because I was constantly changing Option... I gave you that way to reproduce the behavior because it's the shortest and easiest.

    This behavior occurs naturally for me if I run a spell check and add a word to the dictionary, which happens quite a lot. Whenever I do this, spell check starts again either from start or from the place where I last changed text. (I.e. from the currently active segment.) This is not how a spell check should work. It should continue from where it left off. Adding a word does not activate the segment it found the word to be added in, but it is enough to make the spell check stop and require "Resume"ing.

    Daniel