Error message "Object reference not set to an instance of an object" is being shown more often recently

Recently, Studio 2019 has begun to throw the error message "Object reference not set to an instance of an object" more occasionally than before, which makes Studio 2019 appear unstable and also causes specific features or functions to be greyed out and become inaccessible.

Two examples of scenarios where Studio 2019 is (constantly) showing this error message are:

  • When opening multiple files either For Translation, For Review or For Sign-off and then applying a Display Filter on the Review tab in the Editor view, e.g. ”New translated content”, and after that using either the arrow buttons (down and up) or the left mouse button to go to a specific filtered segment and activate it. It doesn’t happen every time you go to a new filtered segment (there is no real pattern), but the error message is being shown quite often, when you do this.
  • When creating a project for Translation Quality Assessment of various files from different ofther projects for regular spot checking and then opening the files (individually) For Review (or For Translation, for that matter), the error message is sometimes being thrown right away, and you then won’t be able to activate ”Assess Quality” (nor ”Track Changes”) on the Review tab in the Editor view. These functions are greyed out and are inaccessible. It doesn’t happen all the time, and it doesn’t happen with all files in the project.

After the error message has been shown numerous times when working on the files in a project, it’s usually very wise to close Studio 2019 and reopen it. Otherwise, Studio 2019 will remain unstable and will often keep showing the error message, when starting working on another project. Sometimes, it will cause different buttons in Studio to be grayed out and made inaccessible. Or you won’t be able to save the project files after having worked on them.

Can you please advise on what to do about this? On how to prevent this error message from constantly being displayed?

Thanks in advance!