numbers not placeable

I am a relatively new user of CAT Tools and I am using the 30-day free trial of Studio 2019. I am translating an editable PDF (not scanned). None of the numbers in the source text are underlined as placeable. I am using a TM, and in settings the box to recognize numbers is checked. Is there something else I have to do? It shouldn’t be a matter of telling Windows to recognize international number formats, because it doesn’t recognize years or footnote numbers, nothing.

Do I have to add a method of recognizing numbers to a variable list? I am unable to download any apps because I am on the free trial. Sorry if I am overlooking something basic.

Parents
  • If number recognition is turned on in the TM settings Studio will recognize numbers in the active segment:

    My settings for this project are default

    Could you send a screenshot of your TM settings and the editor view where the problem shows?

    Allow me to add that any pdf document as source is problematic because pdf is simply not intended to be used as the source for anything - it is just meant to display and print device-independently. You can use pdfs as source in Studio (and in other CAT programs) but it will always add problems.

    Daniel

  • Hi 

    I never experienced this to be unreliable and I can't reproduce your issue:

    Since your source is a pdf file, which is always a possible source of problems, try switching on "Show whitespace characters":

    Other than that, Studio takes number formats from your Windows setup - maybe  can say more about that?

    Daniel

  • Hi , hi 

    2013-2017 is an alphanumeric string because of the dash. This may be why it hasn't been recognised... Can you check the following, Masha, to see if 'Numbers' AND 'Alphanumeric strings' are ticked under the Auto-localisation settings of the language pair (Spanish-English) you're working with:

    If you're working with 'Translate Single File', here is where you find the setting:

    File>Options>Language Pairs>[language pair]>Translation Memory and Automated Translation>Auto-substitution

    If you're working with projects, also if you've already created a single file project, then here is where you can check the setting:

    Project Settings>Language Pairs>[language pair]>Translation Memory and Automated Translation>Auto-substitution

    Try checking the above settings for a start, and let me know if it works...

    I hope it's as simple as this...

    I'm going out now but will check my emails later today to see if that helped.

    All the best,

    Ali 

    PS: Project settings ALWAYS overrule the same settings under File>Options

  • Hi

    Thanks for pointing that out, although this is not a problem with auto-substitution but with number recognition, and has her TM settings right (see her screenshot above).

    Daniel

  • Hi Masha Isle, hi Daniel Hug

    Of course, you're right Daniel.

    I noted that Masha's TM settings are as they should be. It was just that I know the auto-substitution settings don't work unless the same TM Fields and settings boxes are ticked so I just wondered if the opposite could be true.

    A silly idea... iIt isn't. I've tested it, and ascertained that TM settings overrule auto-substitution settings. 

    Language pair Auto-substitution settings:

    TM Fields and settings settings:

    (this last one also accessible via the Translation memories view approach to TM settings).

    With the settings inconsistent as above, the numbers and alphanumerics are still recognised. I should have tested this to be sure before I suggested it. Was rushing out and didn't have time.

    OK, so, looking at Masha's screenshots, I notice something strange. In one particular screenshot, she has variables underlined in segments that aren't highlighted and the numbers in the highlighted segment are NOT highlighted, here: 

    These same numbers are not underlined when they're not highlighted in the other screenshots. Two decidedly odd features.

    Here's how mine look:

    Only the variables in the active segment are underlined, which I think is the default behaviour.

    I wonder why Masha's are different.

    I've checked the PDF filetype settings to see if there's anything there that could make numbers behave differently (given that Masha's file is an sdlxliff made from a PDF). I checked the SDLXLIFF filetype too.

    I also checked the TM Recognised token colour setting under Colour settings and there's nothing there that could make this behaviour so.

    Thus, I suggest that this may be a 'feature' of the 30-day trial settings and once you start using Studio under license, Masha Isle, you will probably find it behaves correctly.

    When I say 'feature' I mean a small bug...

    Paul  or  - what do you make of this? Have I missed something?

    All the best,

    Ali 

Reply
  • Hi Masha Isle, hi Daniel Hug

    Of course, you're right Daniel.

    I noted that Masha's TM settings are as they should be. It was just that I know the auto-substitution settings don't work unless the same TM Fields and settings boxes are ticked so I just wondered if the opposite could be true.

    A silly idea... iIt isn't. I've tested it, and ascertained that TM settings overrule auto-substitution settings. 

    Language pair Auto-substitution settings:

    TM Fields and settings settings:

    (this last one also accessible via the Translation memories view approach to TM settings).

    With the settings inconsistent as above, the numbers and alphanumerics are still recognised. I should have tested this to be sure before I suggested it. Was rushing out and didn't have time.

    OK, so, looking at Masha's screenshots, I notice something strange. In one particular screenshot, she has variables underlined in segments that aren't highlighted and the numbers in the highlighted segment are NOT highlighted, here: 

    These same numbers are not underlined when they're not highlighted in the other screenshots. Two decidedly odd features.

    Here's how mine look:

    Only the variables in the active segment are underlined, which I think is the default behaviour.

    I wonder why Masha's are different.

    I've checked the PDF filetype settings to see if there's anything there that could make numbers behave differently (given that Masha's file is an sdlxliff made from a PDF). I checked the SDLXLIFF filetype too.

    I also checked the TM Recognised token colour setting under Colour settings and there's nothing there that could make this behaviour so.

    Thus, I suggest that this may be a 'feature' of the 30-day trial settings and once you start using Studio under license, Masha Isle, you will probably find it behaves correctly.

    When I say 'feature' I mean a small bug...

    Paul  or  - what do you make of this? Have I missed something?

    All the best,

    Ali 

Children
  • Thanks - hmm, the trial has the same features as the professional version actually - so this should work. I would need to take a look at the project/SDLXLIFF files and settings in question to be able to see if I could help... Thanks, Daniel

  • Hi , hi

    In that case, Daniel, I don't know what to suggest, apart from a Windows repair of Studio. Would you try that please, Masha:

    1. Close all SDL applications.
    2. Open the Control Panel:
      • Windows Vista/7Start > Control Panel > Programs > Programs and Features.
      • Windows 8: Right-click on the screen at bottom-left corner and choose Control Panel > Uninstall a Program.
      • Windows 10: Right-click on Start > Control Panel > Select View by: Small Icons > Programs and Features
      • - or type 'Control Panel' in the search line on your bottom Windows toolbar.
    3. Click/highlight the relevant SDL product from the list (e.g. SDL Trados Studio 2019 etc) and click 'Repair' either on the top toolbar or on the right-click dropdown menu.
    4. Restart Studio.

    Let us know, Masha, if this makes any difference...

    All the best,

    Ali :)