About non-breaking space in Trados Studio 2019

I'm using Trados Studio 2019 and I found the following issues.

I'm not sure if there are solutions to them.

If no, you may consider to fix them in the future upgrades.

1. Non-breaking spaces are not shown in the translation (Target Language: Taiwan Traditional Chinese) even "Show Whitespace Characters" is turn on. Only the non-breaking spaces in the source is visible.

2. The non-breaking space in the beginning of a segment is automatically removed in Trados Studio. However, when the package is imported back to the Worldserver, the white space is automatically added back. It would cause an issue that if the non-breaking space is redundant in the translation.

Thank you.

Ricky