Source file/path of TM units not displayed in Studio 2015

Hi all,

I recently transferred my Studio licence to a new computer and was offered a free upgrade from Studio 2014 SP1 to Studio 2015 SR3, which I accepted. Installation worked fine and the existing TMs can be accessed without major problems.

However, the source file/path of the Translation Units (TUs) within the different TMs is no longer displayed, except for files that had been aligned, but not for the TUs that were included in the TM upon translating. The only reference I can see is the date of creation and the source TM (usually my master TM). When working with different versions of the same document, I like to see which previous version the TM proposal is taken from.

The same happens with new TUs that are included in the TM when working with Studio 2015: there is no hint regarding the source document. So the fact that the location of the source files on the new computer has changed can’t be the reason.

The source files are all Word files, by the way.

Any suggestions on how to fix this?

 

Regards,

Andrés

Parents Reply Children
  • Is it then possible that Studio 2014 already came with this plugin pre-installed? I haven't downloaded any plugin while using Studio 2014.

    To my best knowledge, there were never any plugins pre-installed.
    Perhaps you just don't remember that you installed it. Why not go back to your old computer and check?

    but how can I see the source of the existing TUs in my TMs?

    You can't. Unless they were explicitly added by particular process (like the Record Source TU plugin, or the alignment process), they are simply not there.

  • As far as I understand, the name of the source/target file is "stamped" on each Translation Unit.

    No, it's not, Studio itself does not do this.
    It's a result of having the Record Source TU plugin installed: appstore.sdl.com/.../

    Or... the users manually set the name of the file in the TM update settings after creating a field for this in the TM.  Some users do this quite diligently and this has been possible since 2009.

  • Why not go back to your old computer and check?

    Because I had to deactivate my 2014 licence on the old computer before installing 2015 on the new one, and when I saw that everything apparently worked fine, I removed all data from the old computer.

    Or... the users manually set the name of the file in the TM update settings after creating a field for this in the TM.  Some users do this quite diligently and this has been possible since 2009

    I have no recollection of doing this, Paul, and actually I am not sure if I understand you correctly. As far as I see, in the TM update settings I would have to set the name or path for each new translation individually, i.e. this wouldn't happen automatically. This is what you wrote in your blog post where you suggested installing the RecordSourceTU plugin:

    I can assure you that I never change any field values before starting a translation, and yet in Studio 2014 the path of the source file was displayed for all TUs. This is very strange.

  • Let bygones be bygones
    version 2014(2015) ?  nah.. nobody cares

    Hi  Actually, 'nobody cares' just isn't true. If it were true, , and would not have replied to this post!

    Hi 

    Have you also updated MultiTerm?

    This is a basic suggestion but try a Windows Repair of Studio and MultiTerm components, as here:

    1. Close all SDL applications.
    2. Open the Control Panel:
      • Windows Vista/7Start > Control Panel > Programs > Programs and Features.
      • Windows 8: Right-click on the screen at bottom-left corner and choose Control Panel > Uninstall a Program.
      • Windows 10: Right-click on Start > Control Panel > Select View by: Small Icons > Programs and Features
      • - or type 'Control Panel' in the search line on your bottom Windows toolbar.
    3. Click/highlight the relevant SDL product from the list (e.g. SDL Trados Studio 2019 etc) and click 'Repair' either on the top toolbar or on the right-click dropdown menu.
    4. Restart Studio/MultiTerm.
    If that doesn't help, try reinstalling both Studio and the same year of MultiTerm from your account.
    If that doesn't work, then you have the right to contact Installation Help free of charge, here:

    installation and licensing help

    Select 'Installation' from the 'Case type' dropdown menu.

    Someone will help in the next day or two if you give your correct email address.

    All the best,

    Ali :)

  • Hi 

    I'm sorry, I didn't see your reply. I've been hyper-busy these last few weeks.

    I recommend installing MultiTerm because it is so useful. I don't know whether not having it installed at all would cause issues with Studio 2015.

    However, it is SO useful as it expands the functionality of Studio. Even if your clients don't give you glossaries, you can create your own to ensure better consistency. I always make my own client-dedicated glossaries and find them invaluable. 

    Here is the MultiTerm 2015 online manuel: SDL MultiTerm 2015

    And Studio 2015: SDL Trados Studio 2015 SR2

    Some of the links may not work, this online documentation was set up before the SDL site was redesigned.

    Were you able to resolve your original problem? If not...

    It is possible to use 'Windows Repair' on the newest version of Windows 10. You just need to type 'Control Panel' in the 'Type here to search' line at the left hand end of your bottom toolbar next to the Windows symbol.

    Then, if 'Small icons' is not set under 'View by', select it then click on 'Programs and Features':

    In the list that appears, highlight 'Studio 2015' and select 'Repair' on the top toolbar OR right-click on 'Studio 2015' and select 'Repair' from the dropdown menu that appears.

    If that doesn't work then you decide to reinstall, do this by doing the same as above on the 'Remove Suite of Products' entry, not on the program entry you clicked to repair.

    If then if that doesn't work you can contact installation and licensing help as I described above.

    All the best,

    Ali

  • Hi Alison,

    I very much appreciate your help. This time I did find the "repair" option in Windows, but as far as I can see, the repair of the 3 SDL elements that offer this option didn't change anything within Studio.

    Regarding MultiTerm, I am sure it is very useful for many translators, but I am quite happy with the concordance search, and most of the terminology I need can easily be found online. Since I deem it highly unlikely that MultiTerm has anything to do with my issue, I do no see any reason to install it.

    A complete reinstall of Studio might make more sense, but I would lose the customisation. Given the plethora of bugs and issues reported, also on later versions, I am very lucky that the software is running at all and - in very general terms - doing what it is supposed to do.

    What I will probably do is to install the Plug-in "RecordTU" so I can at least see the source of the TUs created from now on.

    Regards,

    Andrés

  • Hi 

    Actually, as this is a new installation, you already have the right to contact installation and licensing help as I described above.

    Otherwise, I wish you all the best with your work!

    All the best,

    Ali