Cannot add new multiterm databases

Studio 2017 will sometimes not allow me to add a newly created termbase to a new project I am creating. I just get a cryptic error message: “General error occurred. MultiTerm is unable to retrieve the multimedia object.” Funnily enough, sometimes, a few days later, I can add the termbase. Happens with every project where the customer sends me a new multiterm database to use … Only since last summer …
If you need more detailed Information: I work with SDL Trados Studio 2017 Freelance, newly installed on a brandnew Windows 10 computer, installed all the latest updates, no more updates available.
Studio SR1 14.1.10017.45688
MultiTerm SR1
I cannot add any new termbases, neither to my current project nor to my project templates.
By "new termbases" I mean recently created new termbases. Funnily enough, I can add some of my old termbases to my projects and to my project templates without any problems.
I pulled the Internet plug and de-activated my AntiVirus (G Data).
But I still could not add any of my new termbases.
Needless to say, the termbase languages exactly match the project languages
And needless to say, I need to work with the new termbases, not the old ones …
I tried three workarounds. I pulled the Internet plug and de-activated my AntiVirus. Did not help. Then I tried to create a new project template from scratch. Did not help either. Then I copied the project to my Windows 7 laptop computer and tried to add the new termbases to my project using my Windows 7 laptop. Did not work either. I can think of no more workarounds.
And needless to say, I checked SDL Community, several times, and the respective Internet forums andd blogs, but I did not find any similar case.
Thanks for your help.
Parents Reply
  • Dear Paulina,

    Paul Filkin was very helpful, we did have a long remote session. But unfortunately, he did not find any solution either.

    In the meantime, the situation here is as before: Sometimes it works, sometimes it doesn't.

    I have a suspicion, though … Can you try the following: Shut down your computer. Restart it. Do not start any applications or programs or software whatsoever. Now start Studio, and only Studio.

    Can you add your termbase now?

    Wishing you lots of success,


  • Hello Stefanie, thank you for your reply. Oh dear, a glitch so bizarre and mysterious that only a restart can help? I am so eager to start using those termbases that I will try what you recommend. Thank you again for sharing your experience! Take care.

  • Oh dear, so in the end it was all about diacritics.. My ever so HELPFUL & PROFESSIONAL SDL approved reseller discovered via a remote session that:

    - although all Trados related files where stored in the folder called 'Trados', termbases were stored in subfolders containing diacritics in the subfolder names..

    Thank you everyone for bringing up the subject, and thank you Krzysztof Jasianek from LSP SOFTWARE for your proactive approach, amazing customer service and expertise!!!