Any way to turn off currency conversion in the "placeables"?

"Placeable" may be the wrong term: I have a segment which says

"Soit un montant égal à ses droits de 236 504,32 €"

There has previously been another segment with the same words but different number, which I translated as

"I.e. a sum equal to her rights of 555 666,77 €"

What I would like is for SDL simply to substitute the number:

"I.e. a sum equal to her rights of 236 504,32 €".

Instead it simply puts, er, nothing, but it recognises this as a 97% type match. 

So I press Alt-1 and then try and insert the "placeable", which is the whole currency sum, including the "€": but as it does so it tries to be helpful by converting to "€ 236,504.32".

I want to turn this off: I do all my number and currency processing after-the-fact, in a final stage of post-translation, using regex substitutions.  So I just want it to insert "236 504,32 €".

Even better would be for it to recognise that in fact this is an identical match (barring the number), and automatically put "I.e. a sum equal to her rights of 236 504,32 €".

Is there any way to do either of these things? NB my Project Settings --> Language Pairs --> French->English --> Auto-substitution --> Dates and Times: all 7 items are ticked.