Problem with Studio 2019: Delay when changing segments

Dear fellow translators,

I reinstalled my computer and now have a problem with my Studio 2019 (version – it takes about 15 seconds to change segment (move from one segment to another) which is real productivity killer. I am currently working on a not-too-large MIF file received via package. SDLXLIFF file size is about 6 MB. Saving confirmed segments to TM is instantaneous, same as concordance search. Saving the document is quick as well. The document and all TMs are located on an SSD drive, computer is fast enough (16 GB RAM, fast processor).

When I hit Ctrl+Enter to save segment to memory without moving to next segment, there is no delay. After I move to another one (does not matter whether is't translated and stored to TM or not), processor load spikes and Studio becomes unresponsive.

I tried different things:

– reorganizing all TMs;
– disabling all TMs;
– turning off antivirus protection (ESET);
– installing older version of Studio 2019;
– changing spelling checket from Hunspell to Word and vice versa;
– disabling upLift;
– disabling Enable verification of segment option.

None of the above helped. I did not install any other software compared to previous Windows installation.

Any ideas? Thanks in advance!


  • Hi

    Have  you updated MultiTerm to the latest version as well as Studio? You can do this by opening MultiTerm and going to the Help Tab and clicking 'Check for Updates'. It's always important with Studio 2019 to have MultiTerm as up-to-date as Studio is.

    Something else that might help, especially since  you've been reinstalling, is to run a Windows Repair on Studio (and on MultiTerm if you want to):

    1. Close all SDL applications.
    2. Open the Control Panel:
      • Windows Vista/7Start > Control Panel > Programs > Programs and Features.
      • Windows 8: Right-click on the screen at bottom-left corner and choose Control Panel > Uninstall a Program.
      • Windows 10: Right-click on Start > Control Panel > Select View by: Small Icons > Programs and Features
      • - or type 'Control Panel' in the search line on your bottom Windows toolbar.
    3. Click/highlight the relevant SDL product from the list (e.g. SDL Trados Studio 2019 SR2) and click 'Repair' or 'Uninstall/Change' (then Yes then Repair) either on the top toolbar or on the right-click dropdown menu.
    4. Restart Studio/MultiTerm.

    I hope this helps...

    All the best,

    Ali Slight smile

  • Thanks for the reply, Alison. I am using the latest version of MultiTerm. Re-installing Studio was one of the things I tried. Just to be on the safe side, I just tried repairing it, too. Unfortunately, it did not help.

Reply Children