Advanced tab flashes in Studio 2019 or a part of it is missing

Hello,

In Studio 2019, when the cursor is in a segment with "no matches found", a part of the Advanced tab disappears or is missing at all:

So, for example, I cannot use the Insert symbol feature in an empty segment.

In segments with some content, the full tab is displayed:

Sandor

  • Unfortunately, it doesn't help. The same strange behaviour remains.

  • Indeed - I can confirm this strange behavior. In my case the Advanced tab is only partially visible with any kind of segment. However, when I click in another segment, for less than a second more buttons appear on this tab.

    Click here to play this video

  • Actually, a fellow translator called my attention to this problem. She is a user of the old Word-based Trados. Now she has to use Trados Studio for the first time and is quite disappointed about this bug, which was reported over 3 years ago, in Studio 2015 too, as I can see in previous posts. Very sad news...

  • Which particular part of this Advanced tab are you missing so dearly? I would consider myself a power-user of Studio and use this tab maybe 3 times a year...

  • To be frank, I'm also a power-user of Studio but I have not used Insert symbol yet.  But my fellow translator wanted to use it right at the beginning.

  • Adapt ribbon - add a new group to Home tab and add the "Insert symbol" menu there.
    However, I add most symbols via ALT+xxxx code, is much faster...

  • Hi

    Sorry, I wish I had better news for you ...

    I complained about exactly this problem many, many years ago. It persisted from one version of Studio to the next.

    The only "solution" I ever found was to get a new computer, new hard drive, new Windows 10 installation, completely new Studio installation, including creating everything from scratch: a new profile, new project templates, etc.

    But even this was just a temporary reprieve, as the problem has returned since then.

    I imagine that more people would comment here if they were having the same problem, so the echoing silence suggests that you and I are in a very small minority -- which means I wouldn't hold my breath waiting for a solution.

    Or it might be that most users haven't noticed anything useful under the Advanced tab ;-)

    That might sound silly, but I first noticed this problem when someone mentioned the Insert Symbol ribbon -- and I couldn't find it.

    I had looked at the Advanced tab before but didn't see anything interesting -- because the Insert Symbol ribbon was missing!

    I eventually figured out how to make the Insert Symbol ribbon appear again, but it is too time consuming a process.

    This is how to make the ribbon appear again: If the cursor is in an Untranslated segment and the ribbon is not visible, then type something, anything, to change the segment to Draft status. Then move the cursor out of the segment. Then move the cursor back into the segment. Repeat this process every time you go to an Untranslated segment and need a special character.

    Doing that quickly became tiresome, however, so I got into the habit of switching to Microsoft Word (I generally have a Word window open) and getting the symbol there. Fast, easy, reliable and familiar. And the Symbol window that pops up in Word is much faster and easier to use than the popup window in Studio.

    As a result, the Advanced tab became just one more of the Studio "bells and whistles" that I don't use.

  • Hi Bruce,

    How disappointing, indeed.

    My fellow translator who is just trying to use Studio for the first time told me she cannot understand why Studio is crashing/shutting down frequently without any error message. I told her there might be some problem with that specific Word file.  :) I recommended using Ctrl + S (Save) frequently. This is the most important shortcut when I use Studio...

    She told me she cannot comprehend how a program can crash so often. No other programs ever crash at all.

    But Trados Studio does. I can also confirm.

    Studio 2021 is around the corner, and even basic bugs and shortcomings have not been corrected for years.

  • I actually like Studio, in spite of the problems.

    My comment about the bug was more informational: "The bug has been around forever. Don't expect anything soon!"

    And it lets SDL know how to reproducibly Hide/Reveal the Insert Symbol ribbon -- although I think this particular bug will be with us until the user interface is rewritten.

  • And it lets SDL know how to reproducibly Hide/Reveal the Insert Symbol ribbon

    Normally I haven't come across this problem... but I tried again this morning with an sdlxliff file created using a file definition I don't have and low and behold I have the same issue!  That's good news!

    Unfortunately your workaround does do anything for me so I can't validate that.  I could solve it with a "reset window layout" however.

    But even better news is that when I closed the project, activated another, then went back... the features were missing again.  So hopefully this will be reproducible for a developer too!

  • Hi Former Member

    Glad to hear at least some of the problem is reproducible.

    I found that adding and deleting TMs sometimes affected the behaviour of the Insert Symbol ribbon.

    You might want to try the following:

    If you have a project that does not show the Insert Symbol ribbon, then create a new project template based on this project. Call it "test template" or something.

    Create a new project using the "test template". Check that the Insert Symbol ribbon behaves the same as it did in the original project, i.e. it is not visible.

    Now go to the Translation Memories section of the project settings and delete the TMs. Or, if there are no TMs, then add one. Check the behaviour of the Insert Symbol ribbon again.

    Try adding and deleting TMs a few times to see whether there is a reproducible change in behaviour of the Insert Symbol ribbon.

    I noticed a change in behaviour. It will be interesting to see if you also notice a change.

  • As you may have noticed, I also have had this issue.

    Today I tried to adapt the ribbon, but unfortunately not all actions are available to be added (like add confirming segments to the Review tab - was not possible), so I resetted the ribbons to remove a custom group I added to the review tab. This has repaired the issue reported here...

    Maybe that will help you too? Just go to view, ribbon customization and use the reset button there?

  • Hi

    Unfortunately I can't confirm the workaround :-(

    I just went to View->Ribbon Customization->Reset, but the Insert Symbol ribbon still disappears when I place the cursor into a segment with a status of Not Translated ...