Opening packages with different character encoding (UTF on SJIS system locale)

I have recently been having trouble opening Trados packages that use different character encoding. My Windows 10 system locale is set to Japanese, but packages from one of my clients seem to be encoded in UTF. When I open the package, it throws an error due to being unable to open the file due to the filename becoming garbled. My theory is that it is a problem with the way trados uses the windows locale to determine how to unpack the sdlppx file (effectively a zip file), but I am at a loss on how to resolve the issue.

As a workaround, I have set my second PC's locale to UTF-8, and open packages there before transferring them back to my main PC, but it is a clunky fix that I would like to avoid.

My systems are:

Main PC

OS: Windows 10 Pro

System locale: Japanese (SJIS)

Trados version: 2019 SR2 15.2.0.1041

Laptop:

OS: Windows 10 Home Premium

System locale: UTF-8 (Beta)

Trados version: 2019 SR2 15.2.0.1041

I have a feeling this might be more of a Windows/ZIP problem, but it is taking about 5-10 minutes out of my day every time I get a UTF package.

  • I'm not clear whether you are unzipping the SDLPPX first to handle the files inside, or if you are using Trados Studio to open the package?  It's this part that throws me:

    I have a feeling this might be more of a Windows/ZIP problem, but it is taking about 5-10 minutes out of my day every time I get a UTF package.
  • Just opening as usual by double-clicking, but you can peek at the innards of the file using a zip program.


    Trados throws errors whenever it encounters Japanese characters with the dodgy files, so it will sometimes happen when trying to load in the project file and other times it will refuse to load TMs (if the project filename only contains ANSI characters). I thought it might be a bad windows install, but the same behavior occurs when I reverse the system locale on my two PCs.

    I am at a loss. It isn't an issue with most of the packages I receive, so it might actually be weird settings on the PCs of one or two people making the packages.

    Anyway, yell if anyone has experienced anything similar.

  • Have you tried opening the package from within Trados instead of double clicking it?

    Can we see one of these packages?

  • I had the same behavior when opening from within Trados. I can't share any of the packages due to confidentiality issues. I just received one package from the same client that presumably had the same problem, but Trados managed to fix the problem after showing a message saying that it encountered and automatically repaired problems with file names.

    I tried reopening a package I had problems with before and it opened without hitch, so I think my problem may have fixed itself, perhaps through the Windows update that occurred when I rebooted this morning.

    Anyway, please consider this resolved for now because I am unable to reproduce the problem.