I can't change the languages on Trados

Already (de)activated and reinstalled the software (which is something absurd to have to do just to change a language, but anyway...).

Already repaired, did everything, and it keeps preventing me from changing them.

Can someone help?

  • It's always helpful if you tell what version of Trados you're using... but perhaps this will help anyway, assuming you are using the Freelance version of either Trados Studio 2017 or 2019: 

    • Close Studio.
    • Hold down the windows key and press R. (or right click the start/windows button and select Run).
    • For Studio 2017 paste in this:
      reg delete HKEY_CURRENT_USER\Software\Microsoft\LDSRClient5 /f
    • Press ok.
    • Restart Studio.
    • For Studio 2019 paste in this:
      reg delete HKEY_CURRENT_USER\Software\Microsoft\LDSRClient15 /f
  • I have had some success using regedit.  The most recent time I did this was with Studio 2014 or 2015, when the language codes in the registry appeared to be the same as they were for Trados 2007.  A nice list is available at https://www.vivtek.com/trados/trados_2007_language_codes.html .  The language codes appeared to be the same as for Trados 2007, but might be different now.  I can't remember the name of the registry key that you need to edit (perhaps it's the one Paul Filkin references below), but it will be obvious because you will see a single 10-digit number containing 5 2-hexadecimal-digit language codes which match your current language settings.  Just change this number to match the languages you want, and save.  All the usual precautions for registry editing apply.