Change of basic language pairs

Hi, Given the fact that a new Trados will come up soon (I have already purchased it) I want to know how I can change a not installed language pair. I have installed Spanish - German, English - German, Portuguese - German. Now I work more than one year with Dutch - German -- in MemoQ because this language is not installed in my Trados and I have no clue how to do that I want to know whether Iwith the new version I have to kick out Trados 2019 and install 2021 from the scratch or how can I remove Portuguese - German for example, that I do not use anymore and add Dutch - German. That is what I wanted to do log time already but ma installed MemoQ was closer than the Trdos support. But wit the new version I do not want to miss that opportunity. Thank you Peter

Top Replies

  • Hello, 

    You do not select language pairs, once SDL Trados Studio is installed for the first time it allows you to choose your 5 languages. In order to change them, you need to reinstall it.

    After Studio is reinstalled, then you can select:

    -Spanish

    -German

    -English

    -Portuguese

    -Dutch 

    Regards

  • Hi

    As  says, reinstalling Studio may solve this problem.

    If it does not, there is another way to reset your installed languages which will then prompt you to enter your 5 languages when you next open Studio...

    It is possible to reset the entry in the computer Registry to do this.
    You can either do it yourself, or contact Installation Help to ask them to do it...
    IF AND ONLY IF you feel confident about editing the registry, here are instructions.
    Follow them precisely because editing the registry is a risky business...

    Close all SDL products.

    In your 'Type here to search' window at bottom left of your screen, type 'regedit'.

    Open the Registry Editor.

    Either search manually:

    The actual address for Studio 2019 is HKEY_CURRENT_USER\Software\Microsoft\LDSRClient15 (see other version numbers below*)

    Or use the search box:

    Click on 'Edit > Find' or use Ctrl+F 

    In the box that appears, type 'LDSRClient15' for Studio 2019 then hit 'Find'

    *it would be 'LDSRClient5' for Studio 2017 or -1,2,3 or -4 for earlier versions

    The search will take a while as the registry is very long and very complex:

    When the registry key appears, right-click on it and select 'rename'. 

    Add 'old' to the end of the LDSRClient15 (or -1,2,3,4or5) Name.

    Close the registry.

    Open Studio and you should find that it prompts you to add your 5 languages again. Note that you don't need to add more than one variant of any language as all other variants of that language will work once it has been added, and you need to include your usual source language only once.

    Only do this if you feel confident enough to change your PC registry. If not, contact installation support here:

    Installation support

    Fill out the form, tick 'Installation' on the Case Type dropdown menu, explain that reinstalling did not solve your problem, quote this post as they may not know how to do the above, and give them an accurate email address to contact you on.

    All the best,

    Ali Slight smile

  • Hi Ali

    That was the very best answer and solved a long lasting problem. It tooks 10 minutes with 9 minutes for the registry search. Thanks a lot.

    Peter

  • Hi 

    Excellent! Glad to hear that!

    All the best,

    Ali Slight smile