Trados (2017/2019) resetting the MS Word normal.dotm template - possibly related to Embedded Preview?

Hello,

I have seen a couple of other posts mentioning this (or a seemingly similar) problem in these forums and on ProZ, but haven't found any solutions.

I'm using MS Word 2016 and Studio 2019 (although the issue occurred when I was using Studio 2017 too).

Basically, it seems that Trados is somehow causing the MS Word Normal.dotm template to reset itself, meaning I lose all of my customised Word shortcuts.

Other people have suggested the Spell Checker could be causing interference, but I get the impression it's the Embedded Preview that's the problem, because I think (I'm not 100% sure) I've always used the Hunspell spell checker in Studio.

There are no error messages or apparent problems while I'm working in Studio with the Embedded Preview open. However, some mornings when I start my computer up, before I open Studio (or Word), Word opens up a whole load of documents and pop-ups. Some of these documents are blank, and some contain segments from the project I'd been working on in Studio. I can close all of these manually and open Studio and work normally, but when I next find myself working in MS Word, I realise that all of my MS Word shortcuts have been wiped again.

I realise this probably doesn't pinpoint the issue specifically enough, but has anyone experienced the same thing? Or does anyone have suggestions for how to test this more systematically and work out what's going on?

Thanks,

Hayley

Parents
  • Do you save the preview?  Just wondering how you work with this to try and help as I'm not aware of a problem like this.  Maybe saving it is overwriting your templates somehow?

    Try using the HTML preview for a while instead and see if the problem continues?  Or even try not using the review at all for a while?

    Do you have any other add-ins to MS Word that operate with your Word template?

    I do think it's pretty unlikely that Studio is at fault here, but we have seen very surprising things occurring in the past so I won't rule it out!!

  • Hi

    I'm not sure what you mean by "saving" the preview, so I guess the answer is no, I don't. I just have the "Embedded preview" window open while I'm translating in Studio to see the context of segments.

    As far as I know, the only thing I've customised in Word and that are saved to the Normal.dotm template are my shortcuts. I don't believe I've installed any add-ins. The add-in list shows this:

    I will try and observe/note what's happening, but it's tricky because there are no error messages or problems, and it doesn't seem to happen every day/with every document.

    I found this thread on ProZ which suggests somebody else was having a similar problem (see the very last post in the thread, by ). I've sent a message to Alonso on ProZ to ask if he ever found a solution to the problem.

    Hayley

Reply
  • Hi

    I'm not sure what you mean by "saving" the preview, so I guess the answer is no, I don't. I just have the "Embedded preview" window open while I'm translating in Studio to see the context of segments.

    As far as I know, the only thing I've customised in Word and that are saved to the Normal.dotm template are my shortcuts. I don't believe I've installed any add-ins. The add-in list shows this:

    I will try and observe/note what's happening, but it's tricky because there are no error messages or problems, and it doesn't seem to happen every day/with every document.

    I found this thread on ProZ which suggests somebody else was having a similar problem (see the very last post in the thread, by ). I've sent a message to Alonso on ProZ to ask if he ever found a solution to the problem.

    Hayley

Children
  • Things have changed a lot since Studio 2011/2014 and even then I'm not sure Studio was the cause of this.  I think we'd see a lot more threads than this if the issue was related.  However, will be interesting to see what you find.

    There are some interesting discussions in this thread you might find helpful:

    https://answers.microsoft.com/en-us/msoffice/forum/all/word-normaldotm-keeps-resetting/68aeeae1-2b6c-4267-a6a4-7f072feef8bb

  • Hello, Paul

    Studio is certainly the cause. I have no doubt about it.

    Another issue is that it disconnects from Microsoft spell checker from time time, rather often, and it is necessary to restart Studio.

    I actually love the product and I have already pre-ordered Studio 2021. I hope the programmers are aware of this uncomfortable issues and have addressed them. 

    Good day!

  • I asked a developer this afternoon what could be the cause of this and he suggested spelling and grammar, which is in line with the thoughts from Hayley. 

    Perhaps we can do some tests.  Can you make sure that you are not using the Microsoft spellchecker, and if you happen to use the Grammar checker plugin can you remove that too.  Then run for a while without them and see whether this problem still occurs?

    These are apparently the only two things that might still interact with the Word template in some way.  If we can validate this as the cause then the problem is how to figure out why this is a problem for you guys specifically.

  • No, it is not a problem for  and  specifically, other Studio users suffer from the same problem silently. Each and every time I shut/save a MS Word file I get an additional message asking me if I want to save my "new" MS Word "Normal" template and every time I must click on "No" and I confess that I had not connected my problem with my use of Studio (hence my silenceGrinning); BTW, I use the embedded MS spellchecker and not the HUNSPELL one.

  • Hello, Gérard

    I also use MS spellchecker. It disconnects with an error and I have to close Studio, reopen and activate spelling check as you write. 

    Yes, I did not explain very specifically what I meant by "disconnects". Spelling while you write is turned off and will not work until I close and reopen Studio.

    Good day!

  • Hello ,

    I was not not clear enough: I have no problem whichsoever with the Studio spellchecking. My problem is strictly with MS Word and is likely to be connected with something similar to your problem discussed here.

    Cordialmente.

  • Thanks to everyone who has commented. I posted in a Facebook group for Studio users too (here) and so far 9 people have replied saying they also have the issue of MS Word opening up lots of (sometimes blank) files. Admittedly they don't say they've had a problem with the Normal.dotm template (but I suspect that could be because they haven't customised anything in there, so aren't noticing that it's being wiped).

    I've just double-checked that I'm using Hunspell in Studio and not the MS Word spell checker, and am going to see what happens over the next week or so. I'll post any additional observations here.

    Hayley 

  • Hello, Gérard. I did understand your comments. I just added some information about my own issues. Good day!

  • Hi Paul, I thought I should let you know I am also having the same problem so I won't be one of the silent sufferers Wink. Word's normal template is altered by Trados. And one or more documents with some text taken from the Trados segments cause the Windows "Program preventing shut down" message to appear when trying to shut down. 

    Here is what I know. I hope it helps in some way.
    - I don't use Preview.
    - I was using Hunspell until my job required us to change to Word Spell Checker. It was after that that the problem started, but I don't know what version of Trados it was at the time (sometime last year), but right now I am using Trados Studio 2019 SR2 - 15.2.5.2145.
    - The problem happens like this: After using Trados, when I shut down my computer, it says a program is preventing shut down. I used to leave it alone and it would eventually shut down, but then the next time I started up, I would get a message saying the Normal.dotm has been edited. I would tell it to not save. Several Word files with bits and pieces of text from the Trados files I was working on would open saying they were autorecovered and need to be saved. I wouldn't save those either.
    - Recently, the length of time it took for the computer to shut down because of a program preventing it made me wonder what was going on since it didn't happen all the time, so I would cancel the shut down to deal with it manually. When I did, the same messages and files as described above would appear.
    - I also noticed that when I start Trados, and then open a file (a large file when I did it) with Task Manager open, Word would appear in Task Manager but not on the screen. I assume this is the spellchecker working and IMO when the problem is happening.

    Thank you for looking in to this

  • Hello @Paul Filkin and @Brian Lottino

    Two months ago I mentioned higher in this thread that I too was a silent sufferer of this illness. If I am coming back to the thread, it is because before Brian's post nobody had so precisely described each and every symptom of the illness: I could sign under each statement of his.

    My own details:

    • For a few days, I am still using Studio 2019 (15.2.7.2849).
    • I use the MS Word spell checker.
    • I have no plugin installed.

    Two questions:

    1. Should we switch to HUNSPELL to avoid most of the symptoms?
    2. Will this change be sufficient to cure the illness once and for all?