Please note: On Sunday 16th May 00AM – 04AM CEST we will be performing planned maintenance on the RWS Community website. During this time you will not be able to access the website and post/reply. Apologies for the inconvenience.

SDL Trados 2021 Freelance - BUG while working with Concordance Search box

Hello everyone,

I've recently updated my Trados 2019 to Trados 2021 ( I've noticed a bug while working with the Concordance Search box. After trying to copy the results it delivers, the text cursor appears duplicated on the Editor panel and it doesn't let me copy anymore. When I move the cursor inside the Concordance Search box, the duplicated cursor mimics the movement.

Please find attached a video for further reference.

Thank you for your help!

  • Can you confirm your problem is exactly as described in this thread?  I know that this relates to our reference CRQ-20787 which seems to still be an unresolved bug so I'm surprised the support team would tell you this is not reproducible, or that it's your fault.

  • Hej Paul, this is what I wrote

    - The mouse pointer disappears and stays hidden
    - Copying from the editor field does not work
    - Marking of segments does not work
    - Confirming a segment status is arbitrary, sometimes it works, sometimes not, sometimes is miraculously changed into something else again
    - Check document (F8). Errors are displayed but cannot be marked/used. This tool used to be antiquated anyway. Now its useless.

    Reply was : >> A detailed explanation (and screenshots/recordings where possible) of exactly when these issues arise would be helpful as I simply cannot reproduce these and i haven't seen others report this behaviour ...

    and some links to the Wikis (Part 1 and Part 2) 

    I'm sorry but I don't have the time to deal with that. Once the bugs are solved please let me know. The I might give 2021 another try.

    Kind regards


  • ok - so you are adding things that don't relate to this thread?  You are also adding things that I'd have to say I have no idea how to reproduce.  I know you're clearly annoyed by this but the support team, and this community, will be very happy to work through this if you can help show these problems and help us reproduce them.  It's very difficult to fix things you can't reproduce.  Certainly if the things you have listed were a problem for more users I doubt we'd hear the end of it.

    If you ever find the inclination to give the software another go I'd be happy to look at this with you.  But otherwise I can see where the support team are coming from, and they didn't blame you either.  They just need help to be able to reproduce them.

  • Hej Paul,
    I am sorry if I got you wrong. I thought you asked me what my problem was. I didn't know my problem didn't belong here. Maybe I can try and post it in some baking-forum for help. Still I hope that some time I will be able to install 2021 properly. In a year or so. When the bugs are fixed.
    You have been very helpful with other issues before. So I am sure you could help. Then.
    Kind regards

  • I thought you asked me what my problem was.

    I didn't.  I asked you this:

    "Can you confirm your problem is exactly as described in this thread?"

    You responded with a list of things completely unrelated.

    You have been very helpful with other issues before. So I am sure you could help.

    Very willing to help here too.  But we also need a little cooperation or we can't help at all.  All we wanted to do was clarify the issue because it wasn't what this thread was about, and you provided a list of things I could record a video of now and have no problems with at all.

    Perhaps baking might be a good idea after all.

  • I have had exactly the same problem with Studio 2021 from the very beginning:

    - The mouse pointer disappears and stays hidden after a few context searches (it doesn't happen the first few times).
    - Selecting text in the Context search with the mouse and copying does not work, a ghost cursor appears in the source field or the editing section and copies text from there instead.
    - Selecting text in the Context search with the keyboard does not work (Shift + arrow keys or Ctrl + Shif + arrow keys)

    I include a screenshot of how it looks with the ghost cursor marking text in the source section of the context search while I am marking with the mouse in the target section.

    Uninstalling and re-installing Studio 2021 does not help. I'vde tried that with the two updates since the first release, but the problem coninues, which makes it useless.

    At least I still have Studio 2019 in working order. It would have been worse if Studio 2021 would have been my first version of Studio.



  • Hello Paul,

    This discussion has got rather infected, but I hope there will be a solution of the issue soon. It has passed a long time since this thread was started. I don´t know in which extent you are connected with SDL and their support team, but I´ve got the impression that you somehow work for SDL and have been very helpful in solving several other issues with Trados Studio before. Do you know if the SDL support team is working on a solution of the copying problems in the concordance search window in Studio 2021?

  • I can tell you the development team have been working though many reported bugs, but I just tested this again in the beta version of the next release, and the problem described by the original post is still there.  I think it's worth taking the next update, due soon, but unfortunately this one doesn't seem to have made it.  I'll follow up with the dev team and see when it may be planned in.

  • Any news yet?

    This is definitely reproducible. Right after a concordance search, I can copy something from the search results into a target segment. The next time I try and mark something from the same results, the cursor is bugged and copying doesn't work. If I redo the search, though, copying is working again, but just once.

  • I have the same problem, Copy and Insert into document are greyed out in the concordance window, and you can see that the cursor is in the wrong place (source side). The problem seems to have been reported 6 months ago, how come it's not fixed already? Confused

  • I have this problem as well. It keeps me from using 2021 for months now. Very disappointing.

  • Same problem here, although it does not happen every time. Apparently this problem has been known for more than six months now, so I wonder why there STILL is no update in which this major bug has been fixed.

  • I have this problem as well. Very irritating because it really slows me down. Please fix it soon.