SDL Trados Studio 2021, version 16.0.1.2917 crashes frequently while working on the editor

After installing SDL Trados Studio 2021, currently running version 16.0.1.2917, the app keeps crashing while working on the editor on translation mode without error messages. In a good day, the app crashes once or twice, but for example, today it has crashed 10 times (about once every 45 minutes or less). Any solutions?

Top Replies

Parents
  • Hi 

    I find that turning off any 'extra' functionality that I don't use prevents this from happening.

    For example, I don't use fragment matching/match repair...

    So, here in Project settings I turn this off:

    Or if you don't work with projects, i.e. 'Translate Single File', turn off the same settings under File>Options

    (Individual project settings always overrule the same settings made under File>Options)

    I also close the Fragment Matches window in Editor. Most of my work as a proofreader is done in Review mode so I don't need Fragment matches...

    If you don't want to turn off Match Repair or Fragment matching, you can still turn off LookAhead via File>Options, here:

    What I'm saying basically is... turning off anything you don't need/use makes the software more streamlined, efficient and stable.

    If the above doesn't help, it could be that the instability is caused by Studio not being installed in your current environment to the optimum, in which case, take a look at the options here:

    Repairing your installation

    I hope this helps,

    All the best

    Ali Slight smile

Reply
  • Hi 

    I find that turning off any 'extra' functionality that I don't use prevents this from happening.

    For example, I don't use fragment matching/match repair...

    So, here in Project settings I turn this off:

    Or if you don't work with projects, i.e. 'Translate Single File', turn off the same settings under File>Options

    (Individual project settings always overrule the same settings made under File>Options)

    I also close the Fragment Matches window in Editor. Most of my work as a proofreader is done in Review mode so I don't need Fragment matches...

    If you don't want to turn off Match Repair or Fragment matching, you can still turn off LookAhead via File>Options, here:

    What I'm saying basically is... turning off anything you don't need/use makes the software more streamlined, efficient and stable.

    If the above doesn't help, it could be that the instability is caused by Studio not being installed in your current environment to the optimum, in which case, take a look at the options here:

    Repairing your installation

    I hope this helps,

    All the best

    Ali Slight smile

Children
  • Hi Ali! Thanks a lot for your answer. I will try your suggestions and see. However, with the current configuration of my computer, this should not be happening (AMD Ryzen 9 3900X (12 core) and among others, 128 gb RAM memory available) so there are no bottlenecks resourcewise.

  • Hi 

    I know, same here I have a high spec system and it should be able to cope. The above suggestion is just a workaround that sorts the problem for me. The minute a file crashes, I open it and turn off Match Repair in the Project Settings and it doesn't crash again. I'm not saying that Match Repair is the cause of the problem but it solves it if you turn it off.

    When I'm proofreading, working in Review Mode, I always have Match Repair turned off. I use Concordance a lot plus I have 'fuzzy matches' ticked here:

    Thus, similar matches show up. If I want more matches, I reduce the percentage at the top. Then the results are all in one window and I find that easier.

    I have other settings customised too and I change them according to the job/client/context/etc., but I've been using Studio a long time so I've come to know and understand the very many settings there are and what they mean.

    I have always had 'LookAhead' turned off as I noticed that it speeded things up noticeably in Studio 2019.

    All the best,

    Ali Slight smile

  • Hi again Ali!

    So far, I have had no further problems. I just deactivated LookAhead, to avoid deactivating too many of the useful things I use.

    Thank you very much for your detailed help and explanations.

    All the best,

    Jorge

  • Hi 

    I'm very glad that deactivationg LookAhead was enough to manage the problem!

    Great news!

    Ali Slight smile