Why does the PC "grind" when I click back and forth between the translations results window and editor?

This is some high-level "complaining" but it's slowing me down so I'm trying to understand. I am using the latest version of Studio 2021 (SR1 16.1.8.4404)

I use hotkeys to often move from the editor window to the translation results window (or concordance, they are tabbed in the same window on top; it's a conventional setup) to copy text or run searches. Whenever the mouse pointer is moved to the TR window and clicked, even without hotkeys, I get the "grinding wheel" that the program is doing something - always. The same when I click back into the editor window (active row). The grinding only takes place for a couple seconds each time, but a couple seconds is a lot when you do it so often.

I for the life of me can't figure out what the program needs to be looking up here, i.e. the reason for the grind.

Questions:

Is this happening to everyone?

Is there a feature that causes this that can be turned off?

Thanks for any information that can help me!

Parents
  • Hi Michael,

    There are various reasons why this could be happening and various things you can do to improve speed and performance of Studio.

    The following should help here:

    Untick 'Enable LookAhead' via File > Options > Editor > Automation

    This feature basically scans the TM for the next couple of segments for potential translations and on a fast PC this is to speed up the lookup process. However, on an older or lower spec PC it can slow things down.

    Also, a Windows Repair of any large software can smooth performance, especially after an update of that software or of Windows.

    Here is how:

    1. Close all SDL applications.
    2. Open the Control Panel:
      • Windows Vista/7: Start > Control Panel > Programs > Programs and Features.
      • Windows 8: Right-click on the screen at bottom-left corner and choose Control Panel > Uninstall a Program.
      • Windows 10: Right-click on Start > Control Panel > Select View by: Small Icons > Programs and Features
      • - or type 'Control Panel' in the search line on your bottom Windows toolbar.
    3. Click/highlight the relevant SDL product from the list (e.g. SDL Trados Studio 2021 etc) and click 'Uninstall/Change' either on the top toolbar or on the right-click dropdown menu (or just 'Repair' for MultiTerm), then select > Yes > Repair. Allow it to run. This will take longer for Studio than for the 3 main components of MultiTerm. Do NOT repair 'Remove suite of products' entries. These are only for uninstalling.
    4. Restart Studio/MultiTerm.

    Let us know if the above suggestions help or not.

    All the best,

    Ali Slight smile

  • Thanks for your advice; unfortunately, it didn't help. Slight frown

    "Enable LookAhead" has been disabled for me pretty much ever since it was introduced.

    I carried out a repair of Studio as instructed and the behavior continues.

    Could you please tell me if you experience the same behavior? Simply click into a TU shown in the results window and then back to the active row in the editor a few times and let me know if it grinds each time. Thanks! Grinning

  • Am away from my PC but have you also tried turning off Match Repair?

  • Hi again Michael,

    To add to my brief message just now (I'm at the hairdresser's Sweat smile

    Match Repair is very useful but on a less well-performing computer, it can make things unstable. So turning it off (via File>Options if you only work via Translate single file, or if you create all your own projects from scratch, and/or in existing project settings (client based or project template based, for example), then in the project settings will enhance the stability of the program and prevent crashes.

    You asked if I experience this behaviour. I used to on an old low spec PC at all times, so I bought a higher spec PC and now it only happens sometimes if I'm working on a huge, complex project. I reboot the software and the PC now and again in this case, to free up RAM and it does help.

    On my old PC, I turned off all unnecessary features in my profile settings as well as in each incoming client project and that helped...

    How old is your computer and what spec does it have?

    All the best,

    Ali Relaxed

  • Yes, have never used this feature. I'm not sure that this grinding behavior is new.

  • Sorry, only saw the first reply. As I stated, never used that feature, so it can't be that. This behavior occurs on my PC with even a 400-segment file of a couple thousand words. Nothing giant. I've turned off all Lookahead, repair, etc. functions.

    My laptop is about 4 years old but quite reliable: 

    Intel(R) Core(TM) i5-7300U CPU @ 2.60GHz   2.70 GHz

    16 GB RAM

    Have no problems with any other programs. And not really with Trados even when working with projects with 100k to 200k words. Just this little behavior that should in my opinion not happen when clicking from the translation results window back into an active segment, i.e. where nothing at all changes but the cursor position.

  • When you say you've never used it, does that mean you turned it off? I'm asking because it's turned on/ticked by default... ;-)

  • OK, another question... sorry if this is obvious... have Studio and MultiTerm been added to your 'whitelist' as they call it, i.e. your antivirus/firewall exceptions list???

  • I've disabled Match Repair and Lookahead from the beginning. Guess I'm old school that way Wink

Reply Children
No Data