Why does the PC "grind" when I click back and forth between the translations results window and editor?

This is some high-level "complaining" but it's slowing me down so I'm trying to understand. I am using the latest version of Studio 2021 (SR1

I use hotkeys to often move from the editor window to the translation results window (or concordance, they are tabbed in the same window on top; it's a conventional setup) to copy text or run searches. Whenever the mouse pointer is moved to the TR window and clicked, even without hotkeys, I get the "grinding wheel" that the program is doing something - always. The same when I click back into the editor window (active row). The grinding only takes place for a couple seconds each time, but a couple seconds is a lot when you do it so often.

I for the life of me can't figure out what the program needs to be looking up here, i.e. the reason for the grind.


Is this happening to everyone?

Is there a feature that causes this that can be turned off?

Thanks for any information that can help me!

  • Hi Michael,

    There are various reasons why this could be happening and various things you can do to improve speed and performance of Studio.

    The following should help here:

    Untick 'Enable LookAhead' via File > Options > Editor > Automation

    This feature basically scans the TM for the next couple of segments for potential translations and on a fast PC this is to speed up the lookup process. However, on an older or lower spec PC it can slow things down.

    Also, a Windows Repair of any large software can smooth performance, especially after an update of that software or of Windows.

    Here is how:

    1. Close all SDL applications.
    2. Open the Control Panel:
      • Windows Vista/7: Start > Control Panel > Programs > Programs and Features.
      • Windows 8: Right-click on the screen at bottom-left corner and choose Control Panel > Uninstall a Program.
      • Windows 10: Right-click on Start > Control Panel > Select View by: Small Icons > Programs and Features
      • - or type 'Control Panel' in the search line on your bottom Windows toolbar.
    3. Click/highlight the relevant SDL product from the list (e.g. SDL Trados Studio 2021 etc) and click 'Uninstall/Change' either on the top toolbar or on the right-click dropdown menu (or just 'Repair' for MultiTerm), then select > Yes > Repair. Allow it to run. This will take longer for Studio than for the 3 main components of MultiTerm. Do NOT repair 'Remove suite of products' entries. These are only for uninstalling.
    4. Restart Studio/MultiTerm.

    Let us know if the above suggestions help or not.

    All the best,

    Ali Slight smile

  • Thanks for your advice; unfortunately, it didn't help. Slight frown

    "Enable LookAhead" has been disabled for me pretty much ever since it was introduced.

    I carried out a repair of Studio as instructed and the behavior continues.

    Could you please tell me if you experience the same behavior? Simply click into a TU shown in the results window and then back to the active row in the editor a few times and let me know if it grinds each time. Thanks! Grinning

  • Am away from my PC but have you also tried turning off Match Repair?

  • Hi again Michael,

    To add to my brief message just now (I'm at the hairdresser's Sweat smile

    Match Repair is very useful but on a less well-performing computer, it can make things unstable. So turning it off (via File>Options if you only work via Translate single file, or if you create all your own projects from scratch, and/or in existing project settings (client based or project template based, for example), then in the project settings will enhance the stability of the program and prevent crashes.

    You asked if I experience this behaviour. I used to on an old low spec PC at all times, so I bought a higher spec PC and now it only happens sometimes if I'm working on a huge, complex project. I reboot the software and the PC now and again in this case, to free up RAM and it does help.

    On my old PC, I turned off all unnecessary features in my profile settings as well as in each incoming client project and that helped...

    How old is your computer and what spec does it have?

    All the best,

    Ali Relaxed

  • Yes, have never used this feature. I'm not sure that this grinding behavior is new.

  • Sorry, only saw the first reply. As I stated, never used that feature, so it can't be that. This behavior occurs on my PC with even a 400-segment file of a couple thousand words. Nothing giant. I've turned off all Lookahead, repair, etc. functions.

    My laptop is about 4 years old but quite reliable: 

    Intel(R) Core(TM) i5-7300U CPU @ 2.60GHz   2.70 GHz

    16 GB RAM

    Have no problems with any other programs. And not really with Trados even when working with projects with 100k to 200k words. Just this little behavior that should in my opinion not happen when clicking from the translation results window back into an active segment, i.e. where nothing at all changes but the cursor position.

  • When you say you've never used it, does that mean you turned it off? I'm asking because it's turned on/ticked by default... ;-)

  • OK, another question... sorry if this is obvious... have Studio and MultiTerm been added to your 'whitelist' as they call it, i.e. your antivirus/firewall exceptions list???

  • I've disabled Match Repair and Lookahead from the beginning. Guess I'm old school that way Wink

  • Yes, there are no problems here as well. It's "comforting" to me (probably the wrong word lol) that others have this issue. I guess I'm just wondering:

    1) Why is there grinding (i.e. if it's a background feature somewhere, can I disable it).

    2) Is this a bug that can be fixed in a future version of Studio.

    As much as I like using Studio, the UI inside the editor is quite clunky at times. Whether it's working with comments (they jump all over the place, you have to double-click them to jump to the unit) or adding new terms, I believe there are a LOT of places that would increase overall usability. This just happens to be one of them. Wink

  • 1) Why is there grinding (i.e. if it's a background feature somewhere, can I disable it).

    Not as far as I know...

    2) Is this a bug that can be fixed in a future version of Studio.

    I don't think so. Maybe could get someone take a look at your setup remotely and establish whether this is normal or abnormal spooling (grinding) and to look at why you are finding the UI clunky.

    I have no problems with comments and I am not sure what you mean by comments jumping all over the place. Double-clicking a comment to jump to the segment is useful. If you mean that you want to see all commented segments together, you can use the Advanced Display Filter > Filter Attributes >Segment Review > With comments to display only the segments with comments. 

    I have no problems with adding new terms on the fly or in MultiTerm. Do you have the latest version of MultiTerm for the version of Studio you are working with?

    All the best,

    Ali Slight smile

  • Ali, I want to thank you for all your help with this! Grinning

    This probably isn't the place for this but since we're on the subject:

    The "Comments" window works, but it could work a lot better. I've run into situations where I'm 30 comments into 100 and then all of a sudden the comments list scrolls back up to the top. Or when you click on a comment, it grinds for a few seconds. Or when you click on a comment and the software bugs and you move the mouse and it scrolls all the way to the top or bottom (can happen when there are many comments). What I expect is: Click (or double-click) and go immediately to a comment with no grinding, no hassle, etc. I mean, it's 2021.

    As far as adding a new term on the fly. Yeah it works, but I shouldn't have to create a script that executes the Trados hot key for adding a term, then saves the term entry and then moves the cursor back to the active row. Again, with a fair amount of grinding. And sometimes you have to change input models for different term types. Again, I think this could/should all be streamlined.

    The "Messages" window behaves the same way as the "Comments" window, laggy/grindy when I want to see "snappy".

    And for the record (I think I mentioned this above), my laptop is very responsive with all other software I run, so I safely rule this out since these laggy situations occur even with small projects. As I explained above, I am generally a satisfied Studio user; there is usually always a way to accomplish what you want to do. But that doesn't mean that there's not room for improvement.

    If I have the bandwidth tomorrow, I'll see if I can create a video of what I mean and post it somewhere accessible. Never done that before, so we'll see. Maybe someone at RWS will see it. Wink

    But for today, I'm done! Have a great afternoon/evening! Slight smile

  • Hi Michael, just a quick reply hoping I catch you before you sign off...

    I don't have any of the problems you describe. Thus it may be your Studio MultiTerm setup that needs sorting. TBF I don't use AutoHotKey, I've never had the need, but I assume it works well for others or there would be more complaints of the type of performance you describe.

    It would be better if someone from SDL looked at your setup remotely.

    All the best,

    Ali Slight smile

  • Let's see if I can upload my video here Fingers crossed

    It looks like it worked.

    This is a 10k file, and I've only touched upon the grinding when switching windows and in the comments. We'll leave adding terms and the message window for another time perhaps. Wink

  • Hi Michael,

    This slowness switching between windows only happens to me if I'm working on a huge/old format/complex project.

    I do get the spool (grind) icon momentarily here and there, frequently, when working on any job on my main PC but not usually for as many seconds as you do. On my laptop  actions such as switching between windows, adding terms, handling messages, confirming segments, etc., do take longer but I would expect that as it is a lower-spec machine than my desktop PC even though it's relatively new.

    On my old computer, adding more RAM helped this.

    Maybe someone who knows more about this than me can tell you about the processes running behind the program that would be causing this...

    is this something you could help Michael with?

    All the best,

    Ali Slight smile

  • For the record, I just reinstalled Studio 2021 and the behavior has improved; the grinding is not as long as before. Am guessing there's not much that can be done other than to upgrade my hardware. I appreciate the support! Slight smile

  • Glad to hear that the reinstallation helped! 

    We've been beta testing SR2 and have found it goes a little faster so let's hope that will improve performance for you too! A new version of MultiTerm will be launched at the same time and it will be important to install that as well. Nowadays Studio needs the appropriate version of MultiTerm to work to its optimum.

    All the best,

    Ali Smiley

Reply Children
No Data