Error message: Object reference not set to an instance of an object


I am getting an error message (Object reference not set to an instance of an object) when trying to generate a target translation in Studio 2014. 

I have already tried some of the solutions mentioned in the forum but none worked... 

Any ideas?

Here is what I have tried already…..

If Studio starts, but shows the error message Object reference not set to an instance of an object when you switch between different dialogs and views:

    1. Open Studio.
    2. Activate the view where the error occurs (for example the Editor view).
    3. Click View > Reset Window Layout.
    4. Click OK to confirm resetting the window layout.

      If the error message still appears after following the steps above, follow the instructions under Solution 2 below.


      Solution 2

        1. Rename the setting files and run a repair installation

          1. Close all SDL applications.

          2. Go to the following folder: 
            • SDL Trados Studio 2011
              • Windows XPC:\Documents and Settings\[USER_NAME]\Application Data\SDL\SDL Trados Studio\
              • Windows Vista/7/8C:\Users\[USER_NAME]\AppData\Roaming\SDL\SDL Trados Studio\
            • SDL Trados Studio 2014
              • Windows XPC:\Documents and Settings\[USER_NAME]\Application Data\SDL\SDL Trados Studio\
              • Windows Vista/7/8C:\Users\[USER_NAME]\AppData\Roaming\SDL\SDL Trados Studio\

          3. Rename the following XML files (for example, add an underscore before/after the filename):
            • BaseSettings.xml
            • Plugincache.xml
            • UserSettings.xml

          NOTE: If you do not find this folder, make sure that these files are not hidden. See KB article #3330: Show hidden files and folders on Windows operating systems.


      1. Run a repair installation

        1. Open the Control Panel:
          • Windows Vista/7Start > Control Panel > Programs > Programs and Features.
          • Windows 8: Right-click on the screen at bottom-left corner and choose Control Panel > Uninstall a Program.

        2. Click to highlight the damaged SDL Trados Studio version and click Repair.

        3. Restart Studio.