Copying source formatting to target

Hello I'm becoming extremely frustrated with text formatting in the target segments,

I have a document which seems to be reasonably well formatted (typeface and text size) but target segments are highly variable. I don't want to have to copy the source to target segment every time and then delete it. Is it possible to just copy the formatting from source to target? There don't seem to be any tags in particular to copy over.

I've already seen a couple of posts giving quite extensive shortcuts but none seems to include the one I'm looking for.

Thanks, Mark

  • Mark

    You can easily and very quickly transfer formatting from source to target using the QuickPlace function (CTRL-comma or CTRL-click), but you need to do it individually for each tag/tag pair.

    It is not possible to copy the entire formatting because localisable formatting such as bold, underline, italic, footnotes, etc. may be in different places in the target segment than in the source segment, hence the need to transfer them one by one.

    If you want to be sure that you see all tags including the ones that are hidden by default, make all tags visible by clicking on "Toggle formatting display" in the "Option" section of the "view" ribbon.

    Walter

  • Mark

    Please post such questions in the section "SDL Trados Studio" next time instead of in this section, which is reserved for documentation issues.

    Thanks
    Walter
  • Thanks Walter, I tried ctrl , and it suggests formatting options.

    However I dont understand why if all source text is times new, why target text is alternately times or calibri and different sizes.

    Is there no option at least to match source and target at least for font and size, regardless of bold and underline?

    Thanks

  • Mark

    How do you know that your target text has a different font and size than the source?

    Studio does not change nor allow you to change the font type nor the font size of the text you translate. The target segment will always have the same font type and size as the source as this formatting information is not presented to you in the Editor (it is transparent, between the segments).
    However, if there is a font change inside a segment, you will see a tag for this and depending on where you place this tag, the font change will start at a different place, but you cannot decide to change the properties of this font change tag, i.e. you cannot decide to change Arial to Helvetica or font size 10 to 12.

    Walter
  • Hi Mark,

    If you have these changes it is because they are in the source file.  Try pressing Ctrl+Shift+H as this is the keyboard shortcut for the setting Walter suggested you try.  This will allow you to see the formatting tags in the editor and place them more easily.

    It does sound as though you are dealing with a converted PDF perhaps.  It's not uncommon for poor quality PDF files to take on strange characteristics when OCR'd such as the following, all of which are going to be controlled by tags:

    • font changes (size and font type) for no apparent  reason, the OCR tool just thought the font looked different
    • different spacing between the letters
    • different shades of grey when it was probably just all black (or some other colours perhaps)

    There are plenty of other issues possible too.  I'd recommend you review this article from  :

    Regards

    Paul

  • Dear Paul,

    Thank you for your response however I'm not experiencing what you are saying above.

    The original Word document is all in Times New Roman and the final target document is in a mixture of Times and Geneva

    Original in Times 12:

    Text displayed differently in Editor:

     

    Output in Geneva:

  • Dear Mark,

    From your screenshots it looks as though you are not transferring the formatting from the source to the target, and you are also not showing the formatting tags as suggested to make this easier for you to see. Some authors manually change the fonts and misuse the underlying styles in Word. Word doesn't care about this because you never see the control tags, but any CAT tool does care and will need to present you with the ability to handle the control tags because it has no idea whether they are important or not.

    Can you share a small source document containing only this part of the text? It might be easier to see what's going on if we can see the file.

    Regards

    Paul
  • Dear Paul

    I understand about it being the tags setting the target format

    Here in line 4 source the Times tag does not include 'l'autorité compétente" and the target is in the generic font.

    Could I just force all the target into Times?

    Here is a bit (tags display is still on) where there are no tags in the source and the target comes out as per source.

    Regards

    Mark

  • Hi Mark,

    So can we see a small sample of this text to help explain why you are getting what you are getting? Maybe it is a bug, but without a small sample we'll never know.

    Thanks

    Paul
  • Mark

    The segments 2-7 that you show contain tag pairs that format the included text to "Times New Roman" (including the texte "l'autorité compétente").
    As you left these tags out in the target segment, it is obvious that the target text will not be formatted in "Times new Roman".
    Actually, when confirming these segments, you should get a tag error.

    Walter
  • Hi Walter, I have the same problem. And I can see clearly a differt font into the target text. The source is blue and the target is black (just some of the segments), and when I save the target text on the computer I can see also size differences. I have posted an image yesterday, here:


    How can I avoid that?

  • Hi Ana,

    Can you also try pressing Ctrl+Shift+H to reveal any formatting tags.  You should find there are tags controlling the font in these segments that you need to place in the target side.

    Regards

    Paul

  • Done! You are right, there were hidden tags, not really understand why (source text seems to be simple). But repeating tags in the target, makes it equal to the source one, I mean talking about the format. Thanks for your help.
    Regards, Anna