ALT+ DEL (clear target segment) grayed out in Trados Studio 2015 SR2

Since updating to 2015 SR2 I can no longer clear target segments. ALT+DEL does not work and the option in the ribbon and under the right mouse button are grayed out. The segment status of the segments I wish to clear is "untranslated". Has anyone else experienced this and/or does anyone have a solution to this problem?

Top Replies

  • Robert

    If the status of your segment is "untranslated", it should already be empty and there is nothing to clear.
    As soon as a target segment contains any text, the status changes to "Draft".

    Walter
  • Walter,
    The segment had to be merged with the following segment and then cleared so that a concordance search would take place and the target segment would be populated with a close match. I usually hit ALT+DEL to clear the field in this and similar instances, but ALT+DEL has been disabled for some reason. Since I thought it might have to do with the status of the target segment, I set the target segment manually to empty. However, it still contained the text which I wish to clear (hence both empty and containing text). If I press the ALT key, letters light up along the ribbon (the various "ALT+" options), but nothing happens when I press ALT+DEL.
  • Robert

    Does the problem only occur with certain segments or everywhere in this document? What happens if you close the document and open it again? Does it work then?

    Walter
  • Hi Walter,

    My apologies for not replying earlier. It occurs in all segments and reopening the document does not help. I have included a few screenshots below. As you can see, a number of important menu options are greyed out.

    Regards, Robert

  • Can you confirm that you have actually selected a segment?

    Regards

    Paul
  • Yes, this occurs with a segment selected. Other functions are also greyed such as find and replace.

    Regards,

    Robert
  • Hi Robert,

    I have absolutely no clue why this happens. Could we do a skype session maybe... sometime on Monday? Perhaps if I can see your screen something might come to mind.

    Regards

    Paul
  • Hi Paul,
    Was a solution to this ever found? One of my users is currently having the same problem with Studio 2017 (latest version) and Windows 7.
  • Does anyone have a solution to this problem. 3 years on, unfortunately it appears that this problem has not been solved by SDL in the 2019 version. 'Clear target' for some reason has been grayed out and deactivated, no matter how many times I restart Trados.

  • Hi 

    This isn't now and never has been a problem for me... I only have to click into the target segment then right-click on it and I can select 'Clear Target Segment' from the dropdown menu:

    Also, I can clear the target segment using the Alt+Del shortcut.

    I can also perform this action on any number of consecutive segments by dragging the cursor to highlight them then using Alt+Del or right-click>select Clear Target Segment.

    If it has never worked for you then there must be something about your setup that is preventing it.

    All the best,

    Alison

  • Hi Alison,
    Thanks for your suggestion.

    f it had never worked, this would indeed have pointed to a significant compatibility or installation problem on my computer. However, the problem is not permanent, but occurs unexpectedly without any clear cause or solution some time after installation. it is not related to a specific document, as it occurs with all documents.  It is also not a firewall problem. I have checked that. I have also tried removing basesettings.xml, settings.xml and usersettings.xml and then restarting Studio, but to no avail. The problem is therefore not caused by a corrupted configuration file.

    My understanding is that Trados Studio runs on the Java Platform, so I suspect this is a problem with the communication between Trados Studio and Java, in which case this should not occur, in my view, without some sort of error message.

    'Clear target segment' is greyed out and all other options for clearing the target segment (e.g. ALT+DEL) do not work. This suggests to me that some routine in the software has identified some or other permissions issue and has deactivated this function. For instance, in the case of a read-only text, all editing functions would rightly been greyed out. I cannot find any interface with options that indicate that I have limited my ability to clear target segments.

    So, on my assessment, it boils down to a programming issue.

    Regards,

    Robert

  • Hi 

    You say you're using Studio 2019. I'm 99% sure it is no longer Java-based.

    What source file format is this happening with? (Word/XML/InDesign/etc.)

    Do you perform a Windows Repair on both Studio and MultiTerm now and then? This often helps iron out issues, especially after Windows Updates.

    Also, do you always allow both programs to install the latest updates?

    Did you let take a look at this with you via Skype? I'm sure he would be able to troubleshoot this for you...

    All the best,

    Ali Slight smile

  • Hi Alison,

    The files are Word files. However, before replying I converted one to a TXT file and imported it into Trados Studio. The effect is the same. By the way, it is not only 'Clear Target Segment' that is greyed out, but also 'Merge Segments' (under the right mouse button, with the segment selected). In the menu bar, amongst others, 'Replace', 'Merge Segments' and 'Editing' are greyed out, even though I can edit the target text segments. 'Find' is not greyed out, but if I try to search for a word in the document, I receive an error message 'Object reference not set to an instance of an object' (which is reported a language I am not familiar with, namely Gobbledigook).

    Regards,

    Robert

  • My understanding is that Trados Studio runs on the Java Platform

    Trados Studio was never based on Java.
    Some parts of the file type support was, but that's history.
    You can tell that from the fact that Java runtime is no longer part of Studio installer and that the corresponding Settings page disappeared as well.

  • Hi Alison,
    I have found a temporary workaround, although for how long it will work, I am not sure. If I run Trados Studio as Administrator, the menu items are not greyed out. This is very odd, as I have not made any changes to directory permissions or anything similar on my computer.

    Regards,

    Robert