SubRip file type error (Studio 2014 SP2 11.2.4422.11)


Hello everyone,

I am currently working on a subtitling project with multiple files that were apparently created with SubRip.

Although I can open each file individually, I cannot open them all at once: autopropagate doesn't work which is a problem since the project has lots of repetitions.

I downloaded the SubRip file type on OpenExchange but, even after restarting Trados and my computer multiple times, the problem is still the same.

Here is the situation : when I try to open all the files together, an error appears:

***
Une erreur inattendue s'est produite lors de l'activation de l'affichage du document.

System.NullReferenceException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089



Sdl.TranslationStudio.Editor

-2147467261

*** 

When I close this error, another one appears: "La référence d'objet n'est pas définie à une instance d'un objet". (I tried the solution provided by SDL for this one, it doesn't work)

Then, when I open an individual file, nothing bad happens but a message appears in the "Messages" tab in the TM window: "Ce fichier a été créé à l'aide d'une définition de type de fichier qui n'existe pas sur votre système (SubRip v 1.0.0.0). Les fonctionnalités suivantes seront restreintes...".

Let me add that the file type I installed earlier appears in the parameters and is activated (box ticked). I also tried to install it on my other computer with the same Trados version, the problem is the same.

Do you have an idea how to solve this? I also posted this question on proz but no one could help me.

Thanks for your help!