Filter disables TM

Hi,

Created two filters in Project under all Language Pairs - Translation Memories - Filter based on User that last worked on the TU

In Editor, when the filter is used, there are no hits from the TMs - even in Concordance Search mode.

Error message: An error has occurred while using the translation provider NAME OF TM: Object reference not set to an instance of an object.

This is repeated for all TMs used for the specific language pair.

 

In Project Settings, the relevant TMs are enabled, also for Lookup and Concordance

 

SDL Trados Studio 2017, GroupShare.

 

Any ideas where I should start looking for a solution?

9 Replies Latest Replies: 21 Nov 2018 10:19 PM by Paul < 1   2  >
  • Hi

    Is this a GroupShare TM?
    Can you provide details of exactly how you set the filters up?
    Can you provide the error stack and not just the headline? Click on the disk symbol and save the XML to your post.
  • In reply to Paul:

        Hi Paul,

    yes, the TMs are on a GroupShare server.

    First tried setting the filter under All Language Pairs and then under a specific language (pictures Filter_01 and Filter_03).

    Tried Last modified by first with Contains and then with Equal.

    Error lists all language pairs where I tried to translate (picture Filter_02). No access to server TMs, although they were included in Project Settings and Active and I could access the server TMs from the Translation Memories view.

    The above relates to GroupShare.

    (Sorry, I don't have access to the xml file at the moment.)

     

    Tested creating a filter also on a Desktop installation of SDL Trados Studio 2017.

    The result was the same: with a filter (see picture Filter_Desktop), the TM was disabled in the first untranslated segment, with the same error message as in GroupShare (picture Filter_02).

    After I’d deleted the filter, the problem no longer occurred and the TM works fine.

  • In reply to Varpu Vuorjoki:

    Hi  

    I moved your post into the GS forum to see if anyone had any ideas in here too.

    I tested a TM set up as you suggested but don't get an error... so I used this:

    And then see this sort of effect:

    So I believe it "should" work based on my simple test.  It may help if you can get the full error stack as this could point to where the problem is coming from.  Given you get this with file-based and server-based TMs I don't think the condition of the TM is the problem, although it might be worth checking your file-based with the TM Repair app just in case.

    In the meantime perhaps someone here might have a better idea?

  • In reply to Varpu Vuorjoki:

    Hi Varpu,
    in one of the screenshots I see the origin of the error message is the AnyTM provider. Are you using the Finnish TMs through the AnyTM provider? If so, did you try removing the TMs and adding them as normal TMs and then filtering?
  • In reply to Andreas Ljungström:

    Hi Andreas,

    As to the Desktop test:

    The reason for the ANY_TM was that some of the TMs are British English, some American English.

    I disabled all ANY_TMs and had another go with a filter.

    This time the filter did not disable the remaining TM, but it did not work either. Perhaps the filter was not set properly - image attached.

    But this is another, minor, problem.

    The real problem is the filter in the GroupShare environment. I'll add the error  stack once I get back to GS

< 1   2  >
Related