GS 2017 CU11 update - issues with licencing, Studio 2017 client and Online Editor

Hello all,

We are experiencing a number of issues further to the CU11 patch to GS 2017 (TLS 1.0 and 1.1 disabled, TLS 1.2 enabled).

  1. Licence server: we are unable to retrieve Studio 2019 licences from the client (but can retrieve Studio 2017 licences…). The corresponding licences are clearly visible in the SafeNet LM. However, they do not seem to be distributed. Is it the case that Studio 2017 will not connect to the GS under TLS 1.2?
  2. Client-server connections: Studio 2019 (where we still have instances open, see above) connects to the server services ok. Studio 2017 however will not connect to the GS services (credentials rejected). Why would 2017 and 2019 behave differently in terms of licence retrieval?
  3. Online Editor: opens projects with a blank screen (check-in and disconnect buttons visible at the top of the screen). The parser gives two errors:

localhost/.../application.min.js

localhost/.../application.min.css

Would be very grateful if anyone was able to provide any feedback on these issues, especially the licencing matter in the first instance!

Best,

James

Parents
  • We are still seeking a solution to the Online Editor issue:

    1. Online Editor: opens projects with a blank screen (check-in and disconnect buttons visible at the top of the screen). The parser gives two errors:
      1. localhost/.../application.min.js
      2. localhost/.../application.min.css14digits

    Has anybody come across this issue? @Nick Date? Many thanks.

  • Hi James,

    I hope my reply finds you well
    To try and address the Online Editor, issue a starting point would be to check if all SDL services are started on the App Server. Also have a look at the logs from GS. 

    There are quite a few articles that might help and they are worth checking:
    https://gateway.sdl.com/apex/communityknowledge?articleName=000007051
    https://gateway.sdl.com/apex/communityknowledge?articleName=000011594

    I hope this helps.
    Best regards,

    Radu

  • Hi Radu,

    The issue seems to have resolved "itself". 

    However, we are again plagued with the fact that the TM lookup service does not appear to be working.

    We have pushed the TMs up to the top of the project, but this has not resolved the issue.

    Best,

    James

    @Radu Botoiu

  • Hi James,

    In order to resolve this, you would need to edit the AppParameters string for both SDL Feedback Service and SDL Translation Service on the GroupShare Application Server:

    Before making any changes, please back up your AppParameters registries so you would be able to revert the changes should the services not start or if you are facing other issues.

    Please replace [machinename] with your actual machine name where GroupShare is installed [the brackets need to be removed]:

    Feedback Service:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SDL Feedback Service\Parameters\

    -XX:NewRatio=7 -Xmx1024m -jar "C:\Program Files\SDL\SDL Server\Feedback Service\gs-feedback-service.jar" --spring.profiles.active=std --logging.file="C:\ProgramData\SDL\Service\Logs\gs-feedback-service.log" --server.port=41259 --gs.proxy.location=[machinename]:41234 --gs-management-service.ribbon.listOfServers=[machinename]:41234 --translation-memory-service.ribbon.listOfServers=[machinename]:41235

    Translation Service:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SDL Translation Service\Parameters\

    -XX:NewRatio=7 -Xmx1024m -jar "C:\Program Files\SDL\SDL Server\Translation Service\gs-translation-service.jar" --spring.profiles.active=std --logging.file="C:\ProgramData\SDL\Service\Logs\gs-translation-service.log" --server.port=41258 --gs.proxy.location=[machinename]:41234 --gs-management-service.ribbon.listOfServers=[machinename]:41234 --translation-memory-service.ribbon.listOfServers=[machinename]:41235 

    Please note that the Paths to the Services need to be changed/adapted if GroupShare is installed on a different drive than C:\. 

    Once the changes have been applied, restart the SDL Translation Service and the SDL Feedback Service. Log out / Log in to GroupShare and open a file for translation in the Online Editor. You now should have TM and Termbase Lookups.

    It may be required to change the [machinename] to either the FQDN of your Application Server or just the machine name. Please test this with both, but first, just use the machine name.

  • @Radu Botoiu

    Hi Radu,

    Unfortunately, that did not resolve the matter (although both keys did need correcting as they were missing the port numbers and indeed the Translation Service key was truncated).

    The EditorService log indicates:
    2020-06-30 21:50:09.0097|[machine]|Warn|THREAD_ID:23|TR_ID:[hex123abc]|CONN_ID:[hex123abc]|DOC_ID:[hex123abc]|No resources available for lookups!

    There do not appear to be any other relevant log entries.

    Thanks,

    James

  • Hi James,

    Could you please check your Project Settings and make sure that the TM is added to the project under All Language Pairs?

  • Hi Radu, yes I can confirm that it is.

  • Hi James,

    Unfortunately this is not going to be easy to troubleshoot over the forums. Please log a case with us on Gateway and we can set up a remote session in order to check everything and see where this is coming from. 

    Thank you,

    Radu

Reply Children
No Data