How to avoid doubled double quotes?

Hi,

in the source text we have some sentences with a quote e.g. in the middle. No problem so far, when translating in Passolo. However, when we exported it to CSV and had it reimported, the sentences had an additional quotation mark in the beginning and in the end. The additional quotes cannot be seen in Excel but when opened with a simple text editor.

Has anyone a workaround for this problem?

BR,

gabi

5 Replies Latest Replies: 20 Jul 2018 10:47 AM by Birgit Puchner
  • Is there no idea where this effect comes from? For me, the problem has also occurred.
  • When using the Customizable Text Export SDL Passolo is by default using a TAB character as the delimiter to separate columns and no text decoration. To properly import back translations it is expected that the editing tool is not changing the delimiter and the text decoration.

    It seems that the especially Excel is very inventive and is adding text decoration to just some entries, even if not necessary. This why you already see the superfluous character when opening the file in a text editor before importing it into Passolo.

    There are lots of references about this unwanted behavior of Excel in the web but no real solution to prevent this Excel behavior.

    There are various possible solutions for Passolo

    • You can advise translators or reviewers not to use Excel but any other tool that is correctly preserving the CSV structure
    • If there are just some of these entries you can manually remove the superfluous characters before importing the file
    • You can use a tool from the SDL Appstore that has a function to repair the files while importing. See https://appstore.sdl.com/language/app/glossary-converter-for-sdl-passolo/527/ for more details
  • Hi Gabi,

    I understand why you would want to use Excel as a means for translation. The trick is NOT to "export" translation from Excel.

    There is a workaround that we know always worked.

    1. Use Customizable Text Export option - File will be reimported in Passolo option must be checked (see the screenshot below).
    2. Translate it in Excel as usual.
    3. In Excel, select the entire worksheet and copy (Ctrl+C).
    4. Open the original text export file from Passolo in a good text editor. For this step, you will need a good text editor, such as EmEditor (paid) or Notepad++ (free).
    5. Select all the content in the original text export file (Ctrl+A) and hit Delete.
    6. Paste the worksheet content into the export file (Ctrl+V) and hit save. This way, you don't need to worry about encoding, etc.
    7. Import the translated export file into Passolo project.

    I hope this helps.

    Thanks - Naoko

  • In reply to Achim Herrmann:

    Thanks for your explanation.
    We have never come across this phenomenon up to now, interesting.

    You spoke of other tools that are preserving the CSV structure. Can you name but a few?

    And thanks for the link to Glossary Converter. Do you know if they will stay up to date (Passolo 2018)?
  • In reply to Naoko Jones:

    Hi Naoko,
    Many thanks for sharing your workaround. I will try it soon.
    BR,
    gabi

Related