Windows 10 "Let apps run in the background" setting

Mystery solved! 

If you have closed the Studio window and then watched the Studio (SDLTradosStudio.exe) process continue in the Task Manager without terminating for several minutes ...

Or if you have exited Dragon while a Studio or Microsoft Word window is still open, and then watched the Dragon (natspeak.exe) process fail to terminate in the Task Manager no matter how long you wait ...

Or if you have closed Studio while the Dragon process is hung, and then found that the Studio process also hangs and refuses to terminate in the Task Manager ...

... then you might find the following interesting.

The hanging processes caused two problems for me:

First, if I had finished a Studio project and wanted to move the files, I had to wait until the Studio process terminated in the Task Manager. Otherwise, Windows would not allow me to move the files. I often ended up using the Task Manager to kill the Studio process so that I could move the files.

Second, if I used the Task Manager to kill the Dragon process, or allowed Windows to kill the process by restarting or shutting down the system, it did not take long before Dragon started doing strange things.

I was constantly worrying about Dragon or my Dragon profile becoming corrupted. I frequently had to repair Dragon, reinstall Dragon, or create a new Dragon profile, until I found a reliable way to exit Studio and Dragon without causing the processes to hang.

I have now found a Windows 10 setting buried at the following location: Settings -> Privacy -> Background apps (near the bottom of the left-hand navigation pane) -> "Let apps run in the background".

I turned this option "Off", and the Studio and Dragon processes no longer hang. (I am not sure why this setting has an effect on them, since as far as I know Studio and Dragon are not Windows "apps".)

If I exit Dragon while Studio or Word are running, the Dragon process now terminates quickly. (The Dragon process would frequently hang and fail to terminate before.) 

If I close the Studio window, the Studio process now terminates quickly.

I am just guessing, but this may be because I have 32 GB of RAM.

Because I have plenty of RAM, the system might decide to keep the processes in the background in case they are used again soon.

The reason I am guessing this has something to do with RAM is that no one appeared to have the same problem when I mentioned it in a different forum several years ago.

I was running Windows 7 on a different computer at the time, also with a large amount of RAM.

I thought I would mention this here because RAM is a lot cheaper than it was before. If my guess about RAM is right, more Studio or Dragon users might run into this problem now.

Best regards,
Bruce Campbell
ASAP Language Services

 

 

8 Replies Latest Replies: 10 Nov 2017 8:50 AM by Paul < 1   2  >

8 Replies

  • In reply to Michael Beijer:

    PS: I also have 32Gb of ram, but don't have this problem with Dragon. However, I'm hardly using Studio these days, so hard to say what's going on here.
  • In reply to Michael Beijer:

    Hi Michael,

    Thank you for the suggestion, but as you noticed this setting appears to only be intended for what Microsoft considers to be truly "apps", i.e. probably whatever you can install from the Microsoft store.

    That it also affects non-"apps" like Excel is probably an unintended side-effect.

    According to the Task Manager, Excel only shows up in the "Details" tab for around a second each time I view a Studio report when this setting is disabled.

    Unfortunately, once in a while this appears to be long enough for Dragon (DPI15) to get its hooks into it.

    It was bugging me so much that I installed LibreOffice and made it the default office suite. Studio still used Excel, so I guess I missed changing the right file association.

    I finally renamed the Excel program "EXCEL-save.EXE". Now Excel is not invoked and Studio and Dragon are running fast and smoothly all day long.

    There is, of course, no effect on Studio, as it clearly does not need Excel to display a report.

    Probably sloppy coding.

    I was hoping someone at SDL who knew Studio's internals could suggest a workaround, like a registry setting, or precisely which file association should be changed.

    Best regards,
    Bruce
  • In reply to Bruce Campbell:

    The latest Studio update changed the Studio+Excel+Dragon situation again. Viewing a Studio report still invokes an Excel process -- but the Excel process never terminates now if Dragon is running.

    If anyone has the same problem with this background Excel process slowing down Dragon, then it can be solved by tricking Excel and Dragon.

    Dragon is only affected if the Excel Dragon add-in is loaded. If the add-in is not loaded, then Dragon cannot get its hooks into Excel.

    I tricked Excel and Dragon by renaming the Excel Dragon add-in. It can be found here in Windows 10:

    C:\Program Files (x86)\Nuance\NaturallySpeaking15\Program\dgnexcel.dll

    Making sure Excel was not running, I renamed the file to dgnexcel.dll-save, created an empty text file, renamed the text file "dgnexcel.dll" and moved it to the same directory. (Dragon DPI15 complains if a file with this name is not present.)

    Now Dragon does not complain about a missing add-in. And Excel is prevented from loading the add-in, so that Dragon no longer gets its hooks into the Excel process.

    This is actually fine with me. I used to de-activate the Excel add-in anyway, since the Dragon commands I have written for Excel 2016 do not work when the add-in is activated.

    So getting rid of the add-in is beneficial for two reasons. I never used it anyway, so this saves me the effort of de-activating it all the time, and now it can't slow down Dragon.

    Hopefully this will be the last time I have to worry about this.

    Best regards,
    Bruce Campbell
    ASAP Language Services

< 1   2  >
Related