• Not Answered

German umlauts in Studio

I translate from German to English and currently have my keyboard set to the US English International keyboard in Windows 10, which allows me to use key combinations for umlauts and other special characters when I need them.

If I use Dragon (DPI15) and dictate "a umlaut" when the cursor is in a Studio target segment, the letter "q" appears instead of "ä".

The reason this bothers me is that I have several company names defined in my Dragon vocabulary that include special characters. So when I dictate these names into Studio, the special characters like "ä" are replaced by letters like "q".

I can only get "ä" to appear in Studio by changing my keyboard to the German keyboard.

However, when I dictate into a Word file, a web email, Notepad, Acrobat Reader comments, etc. "ä" appears (or "Ä", depending on the context), regardless of the keyboard setting. When I dictate the company names, the special characters are not replaced.

I did find two other places where the same problem shows up.

First, the search box in Windows 10 File Explorer. If I dictate into this search box a "q" appears. (However, when renaming a file in Windows File Explorer, the letter "ä" appears.)

Second, the search box in the comment navigation pane of Acrobat Reader. A "q" also appears here. (However, if I insert a comment into a pdf file and dictate into the comment box then "ä" appears.)

I imagine this means that the SDL has defined the boxes used for target segments in the Studio editor to be like these search boxes instead of defining them like the text boxes used by Microsoft Word, Notepad, Chrome, Acrobat Reader, etc.

Since changing the Studio editor is a low priority for SDL, I doubt this will be corrected any time in the near future.

Has anyone else run into a similar problem with special characters like this, and perhaps found a solution other than changing the keyboard setting (which I am not going to do...)

Best regards,
Bruce Campbell
ASAP Language Solutions

1 Replies Latest Replies: 22 Nov 2017 11:15 AM by Nike L.

1 Reply

  • Bruce Campbell

    Has anyone else run into a similar problem with special characters like this, and perhaps found a solution other than changing the keyboard setting (which I am not going to do...)

    Hi Bruce,

    We had similar problems years ago with French DNS and US International KB. Some accented characters were showing OK in Word but not in Excel - or Studio (they were fine in WB / TE). 

    Nuance support could not help, though they tried for a while.

    Best way is to create another keyboard layout (German), and then switch to it only when you went to dictate into Studio. Create a simple command to switch to the US KB if you want to type something.
     
    Or you can modify your custom command in Studio to auto change the wrong characters when you confirm a segment.
     
    /N

     


Related