Windows 10 "Let apps run in the background" setting

Mystery solved! 

If you have closed the Studio window and then watched the Studio (SDLTradosStudio.exe) process continue in the Task Manager without terminating for several minutes ...

Or if you have exited Dragon while a Studio or Microsoft Word window is still open, and then watched the Dragon (natspeak.exe) process fail to terminate in the Task Manager no matter how long you wait ...

Or if you have closed Studio while the Dragon process is hung, and then found that the Studio process also hangs and refuses to terminate in the Task Manager ...

... then you might find the following interesting.

The hanging processes caused two problems for me:

First, if I had finished a Studio project and wanted to move the files, I had to wait until the Studio process terminated in the Task Manager. Otherwise, Windows would not allow me to move the files. I often ended up using the Task Manager to kill the Studio process so that I could move the files.

Second, if I used the Task Manager to kill the Dragon process, or allowed Windows to kill the process by restarting or shutting down the system, it did not take long before Dragon started doing strange things.

I was constantly worrying about Dragon or my Dragon profile becoming corrupted. I frequently had to repair Dragon, reinstall Dragon, or create a new Dragon profile, until I found a reliable way to exit Studio and Dragon without causing the processes to hang.

I have now found a Windows 10 setting buried at the following location: Settings -> Privacy -> Background apps (near the bottom of the left-hand navigation pane) -> "Let apps run in the background".

I turned this option "Off", and the Studio and Dragon processes no longer hang. (I am not sure why this setting has an effect on them, since as far as I know Studio and Dragon are not Windows "apps".)

If I exit Dragon while Studio or Word are running, the Dragon process now terminates quickly. (The Dragon process would frequently hang and fail to terminate before.) 

If I close the Studio window, the Studio process now terminates quickly.

I am just guessing, but this may be because I have 32 GB of RAM.

Because I have plenty of RAM, the system might decide to keep the processes in the background in case they are used again soon.

The reason I am guessing this has something to do with RAM is that no one appeared to have the same problem when I mentioned it in a different forum several years ago.

I was running Windows 7 on a different computer at the time, also with a large amount of RAM.

I thought I would mention this here because RAM is a lot cheaper than it was before. If my guess about RAM is right, more Studio or Dragon users might run into this problem now.

Best regards,
Bruce Campbell
ASAP Language Services

 

 

Parents
  • Studio and Dragon users beware!

    There is something else you should know about the Windows 10 "Let apps run in the background" setting.

    DPI15 (Dragon Professional Individual 15) doesn't appear to like working with Excel. Other Dragon versions might have the same problem.

    When I view a report in Studio, I see an Excel process start up in the Task Manager (Windows 10), so Studio must be using Excel for reports.

    Sometimes the Excel process terminates quickly, sometimes it just stays visible in the Task Manager.

    When it does not terminate, Dragon starts running slowly.

    However, if you disable the "Let apps run in the background" setting, then the Excel process will terminate quickly so that it does not interfere with Dragon.

    (You might ask why I activated this Windows 10 setting again. Windows 10 unfortunately has a bug. If you disable this setting, then the Windows indexing service stops indexing the start menu. If you install a new program, you have to activate this setting for a while until Windows indexes the new program in the start menu. So I installed a new program, activated the setting -- and then forgot to disable it. I only realized I had forgotten when I noticed Dragon slowing down unbearably and the Excel process not terminating in the Task Manager.)

    Best regards,
    Bruce Campbell
    ASAP Language Services

Reply
  • Studio and Dragon users beware!

    There is something else you should know about the Windows 10 "Let apps run in the background" setting.

    DPI15 (Dragon Professional Individual 15) doesn't appear to like working with Excel. Other Dragon versions might have the same problem.

    When I view a report in Studio, I see an Excel process start up in the Task Manager (Windows 10), so Studio must be using Excel for reports.

    Sometimes the Excel process terminates quickly, sometimes it just stays visible in the Task Manager.

    When it does not terminate, Dragon starts running slowly.

    However, if you disable the "Let apps run in the background" setting, then the Excel process will terminate quickly so that it does not interfere with Dragon.

    (You might ask why I activated this Windows 10 setting again. Windows 10 unfortunately has a bug. If you disable this setting, then the Windows indexing service stops indexing the start menu. If you install a new program, you have to activate this setting for a while until Windows indexes the new program in the start menu. So I installed a new program, activated the setting -- and then forgot to disable it. I only realized I had forgotten when I noticed Dragon slowing down unbearably and the Excel process not terminating in the Task Manager.)

    Best regards,
    Bruce Campbell
    ASAP Language Services

Children