SDL Analyse service not available.

After Paul and Romulus helped and got SDL Analyse running, it is now giving me the old message, "SDL Analyse service is not available, please make sure the service is running." A few days ago, I uninstalled all of the previous versions of Studio (now have only Studio 17 on the computer). That caused the SDL icons to disappear, but repairing Studio brought them back. I suspect this problem is a consequence of these actions. I have run the "Repair" function on Analyse, but without success. I will try uninstalling and re-installing the app now. If this works, I'll write here.

14 Replies Latest Replies: 9 Mar 2017 2:07 PM by Paul Filkin < 1   2   3  >
  • Hello 

    We've been doing more work on this application to try and see how we can simplify the installation for any user irrespective of how they use their windows security.  As a result we think we have resolved this so you do not need to provide any details at all.  We have the first build available for testing and I have decided to start here with you... hopefully you'll give it a shot!

    You can download this Beta version from here and you should then unzip it to your desktop, or other folder on your computer, before running the installer:

    www.dropbox.com/.../Sdl.Community.Studio.Analyse.Installer - 0.51.zip

    Once you have unzipped it you should uninstall the existing SDL Analyse via the Windows Control Panel.  In reality this is probably not needed as the app should clean things up, but I am going to recommend this based on the fact I prefer to do this myself!  Once you have done this run the installer, accept the license agreement make sure you read it... one short paragraph, and click through to Finish.

    That's it.  Now start up Studio and note you will get this warning message:

    This is no problem, we just won't sign the plugin until we have finished all testing with the community.  Once we're happy it all seems to work as intended we'll sign it and place it on the appstore.  I don't anticipate many problems with this... but then I didn't expect so many problems with the previous version until we made it available to everyone outside of our regular Beta Community.  So this is a wider Beta test and I hope you and others will be prepared to try it.  It won't effect the operation of studio at all.

    Looking forward to the feedback... and adding  and  so they are aware of this and it may help with their problems too.

    Regards

    Paul

  • Thanks, Paul! I have followed your instructions, and the app is now running. I have already taken care of the file that came earlier and that I wanted to analyze, but I'm sure another one will come along soon.
  • In reply to Michael Medlinger:

    Hi et al,

    You can now find the production version of the app here:

    appstore.sdl.com/.../

    Simple installation, bugs fixed and ready to go!

    Regards

    Paul
  • In reply to Paul Filkin:

    Hi, Paul!
    Thanks for the info. I have installed the app (without any issues) and it seems to be working just fine.
    Thanks for your support and the work of everyone involved.
    Michael
  • In reply to Paul Filkin:

    Same here! My old SDL Analyse threw a "service not available". That took me here, and I downloaded a new version of the app from the app store. Upon installation all I get is a new error message: "No project templates are defined". Any better solution yet?

    Thanks in advance!
    Eva
< 1   2   3  >
Related