SDL Analyse detects only one language combination and returns zero word count for any other combinations

Hello,

I have been using SDL Analyse on several SDLXLIFF and Word files and I found out that in many cases the analysis returns "0" (zero) for all the items from "Perfect Match" to "Total". I looked into it and I noticed that whenever I perform an analysis the language detected is always "English (United Kingdom)-> Italian (Italy)", i.e. the default languages set in Trados Studio 2017 under Options/Editor/Languages.

Long story short, the analysis works only with generic Word files or with SDLXLIFF files in the ENuk-IT combination, while it shows an all zero word count when I add SDLXLIFF files in the FR-IT or ENus-IT combinations, without any TMs. If I add the relevant FR-IT or ENus-IT TM to any of these files (SDLXLIFF or Word) and run the analysis, the following error message is displayed:

500 - We apologize but an unexpected error occurred. Please try again later.

This happens both in the standalone application and within Trados. No problem at all if I run the standard Studio "Analyze files" batch task. I already have Trados Studio 2017 CU4.

Isn't SDL Analyse supposed to detect the correct language combination when I add a TM or when I performs an analysis on SDLXLIFF files? I also tried to download the app again from the SDL AppStore, to make sure I have the latest updated version, but I got the following error:

How can I fix all this? Thank you!

9 Replies Latest Replies: 11 Mar 2017 11:52 PM by Paul Filkin < 1   2  >
  • Hi Daniela,

    Please check this post:

    community.sdl.com/.../41042

    It is a new build that should have corrected these problems.

    Regards

    Paul
  • In reply to Paul Filkin:

    Hi Paul,

    Thank you for the link. I downloaded the file from Dropbox, removed the previous version and installed this new build from scratch, but the problem is still there. Any other ideas?
  • In reply to Daniela Bollini:

    Hi Daniela,

    Please delete this file and try again:

    c:\Users\[USERNAME]\AppData\Roaming\SDL Community\SDL Analyse\settings.json

    Then also make sure that you set your languages in Studio in here:

    File -> Options -> Editor -> Languages

    If you have any other details behind the error it would be helpful (if this doesn't help).

    Regards

    Paul

  • In reply to Paul Filkin:

    Hi Paul,

    Thank your for your support.

    I deleted settings.json but the problem is still there.

    I changed the default languages in File -> Options -> Editor -> Languages from ENuk-IT to ENus-IT, tried to analyse an ENus-IT SDLXLIFF file and it worked. I then tried to analyse a FR-IT SDLXLIFF file, but the word count was zero again as the language combination was stuck to ENus-IT:

    I also tried to uncheck the "Prompt for document languages if they cannot be detected automatically" box in File -> Options -> Editor -> Languages, but nothing has changed.

    This means that, whenever I need to perform an analysis in a combination other than the one currently set, I should first open Trados, set the relevant language combination and run SDL Analyse, which is a bit frustrating.

    I cannot think of any other relevant detail about this issue. Any other input would be much appreciated, thank you!

  • In reply to Daniela Bollini:

    Hi Daniela,

    I think I missed that you used this on an sdlxliff. I think you have brought to our attention a problem we need to address. The language direction is based on either of these:

    1. The languages you have in your File -> Options -> Editor -> Languages, or
    2. The presence of a TM, either by adding a TM or selecting a Project Template (advanced view)

    So if you add an sdlxliff which already has a language specified, and then don't have a matching TM then it's going to get something wrong. Can you try matching your language settings to the sdlxliff and see if this helps? In the meantime we are looking at this and will release a new version once we have resolved it.

    Regards

    Paul
< 1   2  >
Related