unhandled SEHException

Hi there

I want to access our Multiterm data via the API. I have written a few lines of code in C#, but now I run into an exception that I cannot seem to tackle.

Here is a snippet:
            Application oMt = new ApplicationClass();

            TermbaseRepository oServerRep = oMt.ServerRepository;
            oServerRep.Connect(my credentials);
            oServerRep.Location = (my server);
            Console.WriteLine("Connection successful: " + oServerRep.IsConnected);

            Termbases oTbs = oServerRep.Termbases;

An unhandled 'System.Runtime.InteropServices.SEHException' is thrown at the last line, i.e. when I try to access the Termbases. The line above that shows me that the connection has been established successfully, so no problem there.

Unfortunately, my debugging efforts haven't yielded any result either. Does anyone know how to resolve such an exception?

Thanks in advance!

6 Replies Latest Replies: 6 Jan 2016 11:04 AM by Romulus Crisan < 1   2  >
  • Can you please try to run as administrator?
  • In reply to Romulus Crisan:

    Hi Romulus

    Thanks for getting back to me.
    I'm new to SDL, and I'm not too well versed in Visual Studio either.
    So could you please describe to me how I can run as administrator? Much appreciated.

    I have tried to run the code in release mode and in debug mode, with the same result.
  • In reply to Romulus Crisan:

    Hi Romulus,

    we get the same error in one of the client environments (System.Runtime.SEHException (0x80004005)) with the same test code. We tried with MT Desktop 2015 (latest), MT Desktop 2017, with different users having access to different sets of termbases (one of the users has access to no termbases at all). We used the system administrator user for trying this. => same result.

    We met this error in the past here and there, but then it was usually solved with an MT upgrade or a system restart. But this time we cannot solve it.

    Do you have an idea what to check? Is this some COM permission problem? Should we try to upgrade anything else?

     

    This is the complete test code I used:

    var app = new Application();
    app.ServerRepository.Location = "http://....";
    app.ServerRepository.Connect(user, pass);
    foreach (ITermbase tb in app.ServerRepository.Termbases)
        Console.WriteLine(tb.Name);
    app.ServerRepository.Disconnect();

    Thanks,
    Tamas

  • In reply to Tamás Mészáros:

    We tried to reproduced the problem on our environment but it worked fine. This highlights that there's something with the environment. Would you be able to send some logs from the event viewer or crash dumps?
  • In reply to Romulus Crisan:

    Hi,

    now, we experience this also in one of our systems, right when calling

    var app = new Application();

    (MT Desktop version 14.2.7.43908)

    in another system with 14.0.2094.0 this works still.
    Right after upgrading it to the latest 14.2.7.43908 the same error in this system too.
    I restarted the system, started this app as administrator, same result. 

    Error log is:


    Faulting module name: KERNELBASE.dll, version: 6.1.7601.23796, time stamp: 0x59028e59
    Exception code: 0xe06d7363
    Fault offset: 0x0000c54f
    Faulting process id: 0x168c
    Faulting application start time: 0x01d4c44b13793ae5
    Faulting application path: C:\Users\XXXXXX\Desktop\TestMTApi.exe
    Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
    Report Id: 53fe5e1e-303e-11e9-907c-005056bccf5e

     

    We experience the same issue with MT 2019 (15.0.2.49020) in the customer's environment as well (new installation). The same version in our environment works fine.

    Can you please help?

< 1   2  >
Related