XPP 9.3.0.0 functionality(ctrl+f, page mode editing)

Has anyone seen the below 'oddities' happening?  We are running certification testing on XPP 9.3.0.0 and are seeing these two one-offs.

  • When entering an xpp command close to the end of a line in page view and there is not enough room on that line, the cursor focus moves outside of the tagging when it falls to the next line and allows you to keep typing.
    • Works correctly when in Line Editor or Text view.

  • Scope drop down doesn't work when using Ctrl+F.
    • It does work when using softkey search

  •  I have seen the first issue but normally always do those sort of changes in the line editor or text mode. Have not noticed the second issue but probably because I so rarely use that.

  • Hi John,

    As far as the first problem with typing a macro near the end of the line in Page Mode and the line splits and the cursor jumping out of the macro, this was previously reported by a customer. This problem is fixed already in the XPP 9.3.1.0 Service Pack (CRQ-14133).

    As far as the second problem with the Scope field option arrow in the Search Form for Sdedit (opened via Ctrl+F), it would have been helpful if you had mentioned on which platform you were testing.

    With my first attempt to reproduce it, I was on the Solaris platform (Motif-based GUI) and the problem did not occur. Next I tried on the Windows platform (GTK-based GUI) and the problem still did not occur. Last I tried on the Linux platform (also GTK-based GUI), and voila, there I did see the problem you described. So, I'm assuming that you must be testing on the Linux platform.

    Very strange indeed! Could you please open up a ticket (aka Case) with Support and specify that this is a problem on the Linux (only) platform.

    Jonathan Dagresta
    SDL XPP Engineering

  • Apologies we are indeed on Linux, I will open a ticket.

    Thanks for the quick answer...again sorry for putting you through the extra work.

    John

  • Update: This problem (with the Search/Replace form) has been fixed (XPP 9.4.0) and a hotfix is also available for the XPP 9.3 release (CRQ-17317).

    Jonathan Dagresta
    SDL XPP Engineering