Studio 2019 does not open after SR-2 update, error message about World server, culture

After SR-2 update, Studio 2019 does not open. An error message about culture is shown:

errors_4_community.xml
<SDLErrorDetails time="05-Sep-19 9:26:00 AM">
<ErrorMessage>Could not find any resources appropriate for the specified culture (or the neutral culture) on disk.
baseName: Sdl.TranslationStudio.Plugins.WorldServerTranslationProvider.plugin locationInfo: &lt;null&gt; fileName: Sdl.TranslationStudio.Plugins.WorldServerTranslationProvider.plugin.resources</ErrorMessage>
<Exception>
<Type>System.Resources.MissingManifestResourceException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089</Type>
<HelpLink />
<Source>mscorlib</Source>
<HResult>-2146233038</HResult>
<StackTrace><![CDATA[ at System.Resources.FileBasedResourceGroveler.GrovelForResourceSet(CultureInfo culture, Dictionary`2 localResourceSets, Boolean tryParents, Boolean createIfNotExists, StackCrawlMark& stackMark)
at System.Resources.ResourceManager.InternalGetResourceSet(CultureInfo requestedCulture, Boolean createIfNotExists, Boolean tryParents, StackCrawlMark& stackMark)
at System.Resources.ResourceManager.InternalGetResourceSet(CultureInfo culture, Boolean createIfNotExists, Boolean tryParents)
at System.Resources.ResourceManager.GetObject(String name, CultureInfo culture, Boolean wrapUnmanagedMemStream)
at System.Resources.ResourceManager.GetObject(String name)
at Sdl.Core.PluginFramework.FileBasedPluginDescriptor.GetPluginResource(String name)
at Sdl.Core.PluginFramework.Implementation.PluginResourceManager.GetPluginResource[T](String resourceName)
at Sdl.Core.PluginFramework.Implementation.Plugin.GetPluginResource[T](String resourceName)
at Sdl.Core.PluginFramework.Implementation.PluginDeserializer.InitializeLocalizableProperties(IExtension extension, Object attribute)
at Sdl.Core.PluginFramework.Implementation.PluginDeserializer.DeserializeAttribute(IExtension extension, XElement attributeElement)
at Sdl.Core.PluginFramework.Implementation.Extension.get_ExtensionAttribute()
at Sdl.Desktop.Platform.Implementation.Studio.ExecuteStartupExtensions()
at Sdl.Desktop.Platform.Implementation.Studio.Run()
at Sdl.TranslationStudio.Application.Launcher.RunApplication()]]></StackTrace>
</Exception>
<Environment>
<ProductName>SDL Trados Studio</ProductName>
<ProductVersion>15.0.0.0</ProductVersion>
<EntryAssemblyFileVersion>15.2.0.1041</EntryAssemblyFileVersion>
<OperatingSystem>Microsoft Windows 10 Home Single Language</OperatingSystem>
<ServicePack>NULL</ServicePack>
<OperatingSystemLanguage>1033</OperatingSystemLanguage>
<CodePage>1252</CodePage>
<LoggedOnUser>GURUDUTTKAMATHP\Gurudutt R Kamath</LoggedOnUser>
<DotNetFrameWork>4.0.30319.42000</DotNetFrameWork>
<ComputerName>GURUDUTTKAMATHP</ComputerName>
<ConnectedToNetwork>True</ConnectedToNetwork>
<PhysicalMemory>4069952 MB</PhysicalMemory>
</Environment>
</SDLErrorDetails>

I checked the community and tried opening the WorldServer by doubleclicking on it as recommended. Nothing happens. Urgent help will be appreciated.

Thanks.

Parents Reply Children
No Data