Correction of numbers in Trados 2021

I am currently translating annual financial statements into English, and I have a lot of numbers in this document.

The number format in the source text looks like this: 123 456,78 and the number format in the target text is supposed to look like this: 123,456.78 (In his example, 78 represent decimal places).

Trados 2017 used to make this number conversion automatically and impeccably. I never even thought about it.

Trados 2021, however, is very inconsistent. Some of the target numbers are changed correctly, in others the comas are omitted for some reason. Target segments in the correct format alternate with target segments in the incorrect format. Why is that? How it can be fixed? I do not want to insert the comas manually because the document is too long and the whole purpose of Trados is to save translators from repetitive tasks. Precise instructions will be highly appreciated :).

Parents
  • I have the exactly same problem with the Live as you, and I had to review all the documents I have done to make sure there is no error, which took me much more time than I didn't use Trados. I wonder if you fixed it.

  • No, not really. By default - it is still the way I described it above: utterly inconsistent. However, I found a temporary "fix". When I open a document with numbers, I first go to a segment with a number and use ctrl+comma to choose the correct option for that number. Then it kind of works all right for that specific document. "Kind of" because still some occasional numbers may be incorrect and I still have to manually check every single number just in case and that takes a LOT of my working time. I absolutely hate it. A couple of times Trados just changed all the numbers in a document to the incorrect format after I have already finished it. I still cannot figure out why that keeps happening.... 

Reply
  • No, not really. By default - it is still the way I described it above: utterly inconsistent. However, I found a temporary "fix". When I open a document with numbers, I first go to a segment with a number and use ctrl+comma to choose the correct option for that number. Then it kind of works all right for that specific document. "Kind of" because still some occasional numbers may be incorrect and I still have to manually check every single number just in case and that takes a LOT of my working time. I absolutely hate it. A couple of times Trados just changed all the numbers in a document to the incorrect format after I have already finished it. I still cannot figure out why that keeps happening.... 

Children
No Data