Uploading Large Files to Groupshare

Does anybody have experience uploading large files (say 100 MB or more per file) to Groupshare?
Long story short, I am unable to upload any projects with large files to Groupshare because it takes too long and times out, and was wondering if this is just me?

Also, note I tested the internet speed, and it seems to be fine. Also, Groupshare 2015 never gave us problems like this.

4 Replies Latest Replies: 18 Sep 2018 6:01 AM by Julien Boesen
  • I gave this fact to SDL a few weeks ago. With one of the last changes the time out was set from 60 seconds to 10 minutes.
    I also recommended to create a possibility to reload files individually to increase the file size independent of the time out.
  • Hi Jesse, do you use SDl Studio SR1 CU12 I found taht there is a bug in CU12 when downloading and uplodingt do Grousphare server. My workaround was removed CU 12 and reinsatle CU11 i can tell you that this issue is fixed in CU13 beta. It might bi something like this CRQ-8521 gateway.sdl.com/.../communityknowledge just you don't get error just waiting a long time.
  • In reply to Mitja Kelenc:



    Thank you for the link. Yes, that was *one* of the issues we encountered...
  • Hi Jesse,

    Sorry for the late reply. Here is something that I believe could help you.

     

    Root Cause:

    Limitation of upload speed in Windows 7 causes timeout when uploading file.

     

    Resolution:

    Workaround: Tune upload speed via registry change

    1. Open RegEdit.exe

    2. Go to key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AFD\Parameters

    3. Right click Parameters and select New > DWORD (32-bit) Value

    4. Set to value's name to DefaultSendWindow

    5. Right click DefaultSendWindow and click Modify

    6. Set Value data to e.g. 65536 (Base: Hexadecimal) and confirm

     

    1. Reboot Computer 

    Workaround: Increase Server Farm Proxy timeout in IIS

    On the server where GroupShare is installed:

    1. Open Internet Information Services (IIS)
    2. Expand Server Farms
    3. For all sub-nodes (eg. TMServiceFarm) make the timeout change under Proxy
    4. Increase the timeout from default 30 to 60, 120 or even 180

     

     

    Notes:

    • Increasing the timeout above approximately 100 seconds will have no effect on this particular issue.
    • For very large translation memories, the problem is likely to persist for specific searches. In this case, the error details will be different - A task was canceled instead of Response status code does not indicate success: 502 (Bad Gateway)

     

    Partial Workaround: Decrease Number of translation units per page

    1. Go to File > Options > Translation Memories View
    2. Reduce the Number of translation units per page

    Note: For very large translation memories, the problem is likely to persist for specific searches.
     


    Further notes

    • In some cases re-running the same search may avoid the error.
    • The issue is more likely to occur if there are general performance issues on your GroupShare server. You may want to monitor for hardware bottlenecks - especially if you encounter with issue with TMs smaller than 200k TUs.

     

    Hope this helps. Please let me know if you have any more problems.

     

    Regards,

    Gareth Anderson


Related