How do you pretranslate through the webUI?


We have started to create some projects through the webUI and while we are able to import the templates with the server-based TMs, we are unable to get a pretranslation.
I've found this article :

Unfortunately, it does not seem to work either.

I would like to know if anyone could give me an example of what the credentials are supposed to be. Basically, in server address, I've put the same address as the external server address. In user, i put sa and its password. Unfortunately, no luck on that end either. Perhaps I'm missing something?

I'm currently on CU10

  • Hi ,

    Try the internal server name (or even just use localhost) and make sure you specify https:// if you are using SSL.

    If you are still having trouble then open Registry Editor and modify the following two entries (make a backup of the original values first):

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SDL Feedback Service\Parameters

    -XX:NewRatio=7 -Xmx1024m -jar "C:\Program Files\SDL\SDL Server\Feedback Service\gs-feedback-service.jar" --logging.file="C:\ProgramData\SDL\Service\Logs\gs-feedback-service.log" --server.port=41259 --gs.proxy.location=localhost:41234 --gs-management-service.ribbon.listOfServers=localhost:41234 --translation-memory-service.ribbon.listOfServers=localhost:41235

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SDL Translation Service\Parameters

    -XX:NewRatio=7 -Xmx1024m -jar "C:\Program Files\SDL\SDL Server\Translation Service\gs-translation-service.jar" --logging.file="C:\ProgramData\SDL\Service\Logs\gs-translation-service.log" --server.port=41258 --gs.proxy.location=localhost:41234 --gs-management-service.ribbon.listOfServers=localhost:41234 --translation-memory-service.ribbon.listOfServers=localhost:41235

    You can replace localhost with the fully qualified internal hostname of the application server if you are still having trouble (this may be necessary if your web server is different to the application server).

    Let me know if this resolves the issue.

    Kind regards,

  • Unfortunately, it did not work. The server address is the correct one in the registry (before I changed it to localhost and back to the correct one again), I really think the problem is with the user/password 

    Is the user I'm supposed to put in the field a groupshare user or the internal server user (e.g "admin")? I've tried both but still no results. 

  • You need to put the credentials in of a GroupShare user that has access to the resources that are associated with the projects that you want to create.

    I suggest that you create a user called gsadmin that has the Administrator role in the Root Organisation and then add the account as a Server-based Translation Memory Credential... in the GroupShare Console.

    Note that, if you are using https-only then you must specify this e.g.

Reply Children